Harmony Skill

  • Versuche jetzt seit 3 Tagen den Harmony Adapter zu installieren. Raspi mehrmals platt gemacht, neu aufgesetzt und seit Tagen diese Meldung. Werde noch wahnsinnig, da der Adapter ist schon gelaufen ist. Hat jemand eine Lösung parat?

    $ ./iobroker add harmony

    npm install iobroker.harmony --production --prefix "/opt/iobroker" (System call)

    npm WARN addRemoteGit Error: not found: gitnpm WARN addRemoteGit at getNotFoundError (/usr/lib/node_modules/npm/node_modules/which/which.js:13:12)

    npm WARN addRemoteGit at F (/usr/lib/node_modules/npm/node_modules/which/which.js:68:19)

    npm WARN addRemoteGit at E (/usr/lib/node_modules/npm/node_modules/which/which.js:80:29)

    npm WARN addRemoteGit at /usr/lib/node_modules/npm/node_modules/which/which.js:89:16

    npm WARN addRemoteGit at /usr/lib/node_modules/npm/node_modules/which/node_modules/isexe/index.js:42:5

    npm WARN addRemoteGit at /usr/lib/node_modules/npm/node_modules/which/node_modules/isexe/mode.js:8:5

    npm WARN addRemoteGit at /usr/lib/node_modules/npm/node_modules/graceful-fs/polyfills.js:284:29

    npm WARN addRemoteGit at FSReqWrap.oncomplete (fs.js:152:21)

    npm WARN addRemoteGit

    git+https://github.com/swissmanu/ltx.git#cdata-for-ltx-parser resetting remote /root/.npm/_git-remotes/git-https-github-com-swissmanu-ltx-git-cdata-for-ltx-parser-d923f26b because of error: { Error: not found: gitnpm WARN addRemoteGit at getNotFoundError (/usr/lib/node_modules/npm/node_modules/which/which.js:13:12)

    npm WARN addRemoteGit at F (/usr/lib/node_modules/npm/node_modules/which/which.js:68:19)

    npm WARN addRemoteGit at E (/usr/lib/node_modules/npm/node_modules/which/which.js:80:29)

    npm WARN addRemoteGit at /usr/lib/node_modules/npm/node_modules/which/which.js:89:16

    npm WARN addRemoteGit at /usr/lib/node_modules/npm/node_modules/which/node_modules/isexe/index.js:42:5

    npm WARN addRemoteGit at /usr/lib/node_modules/npm/node_modules/which/node_modules/isexe/mode.js:8:5

    npm WARN addRemoteGit at /usr/lib/node_modules/npm/node_modules/graceful-fs/polyfills.js:284:29

    npm WARN addRemoteGit at FSReqWrap.oncomplete (fs.js:152:21) code: 'ENOGIT' }


    npm ERR! git clone --template=/root/.npm/_git-remotes/_templates --mirror https://github.com/swissmanu/ltx.git /root/.npm/_git-remotes/git-https-github-com-swissmanu-ltx-git-cdata-for-ltx-parser-d923f26b: undefinednpm ERR! git clone --template=/root/.npm/_git-remotes/_templates --mirror https://github.com/swissmanu/ltx.git /root/.npm/_git-remotes/git-https-github-com-swissmanu-ltx-git-cdata-for-ltx-parser-d923f26b: undefined


    npm WARN deprecated node-xmpp-stanza@1.1.0: use @xmpp/xml package <https://www.npmjs.com/package/@xmpp/xml>

    npm ERR! code ENOGIT

    npm ERR! not found: gitnpm ERR!

    npm ERR! Failed using git.

    npm ERR! This is most likely not a problem with npm itself.

    npm ERR! Please check if you have git installed and in your PATH.


    npm ERR! A complete log of this run can be found in:

    npm ERR! /root/.npm/_logs/2018-08-06T19_42_30_493Z-debug.log


    host.raspberrypi install adapter harmony

    npm install iobroker.harmony --production --prefix "/opt/iobroker" (System call)

    npm

    WARN addRemoteGit Error: not found: gitnpm WARN addRemoteGit at getNotFoundError (/usr/lib/node_modules/npm/node_modules/which/which.js:13:12)

    npm WARN addRemoteGit at F (/usr/lib/node_modules/npm/node_modules/which/which.js:68:19)

    npm WARN

    addRemoteGit at E (/usr/lib/node_modules/npm/node_modules/which/which.js:80:29)npm WARN addRemoteGit at /usr/lib/node_modules/npm/node_modules/which/which.js:89:16

    npm WARN addRemoteGit at /usr/lib/node_modules/npm/node_modules/which/node_modules/isexe/index.js:42:5

    npm WARN

    addRemoteGit at /usr/lib/node_modules/npm/node_modules/which/node_modules/isexe/mode.js:8:5npm WARN addRemoteGit at /usr/lib/node_modules/npm/node_modules/graceful-fs/polyfills.js:284:29

    npm WARN addRemoteGit at FSReqWrap.oncomplete (fs.js:152:21)

    npm WARN addRemoteGit git+https://github.com/swissmanu/ltx.git#cdata-for-ltx-parser resetting remote /root/.npm/_git-remotes/git-https-github-com-swissmanu-ltx-git-cdata-for-ltx-parser-d923f26b because of error: { Error: not found: git

    npm WARN addRemoteGit at getNotFoundError (/usr/lib/node_modules/npm/node_modules/which/which.js:13:12)

    npm WARN addRemoteGit

    at F (/usr/lib/node_modules/npm/node_modules/which/which.js:68:19)npm WARN addRemoteGit at E (/usr/lib/node_modules/npm/node_modules/which/which.js:80:29)

    npm WARN addRemoteGit at /usr/lib/node_modules/npm/node_modules/which/which.js:89:16

    npm WARN addRemoteGit at /usr/lib/node_modules/npm/node_modules/which/node_modules/isexe/index.js:42:5

    npm

    WARN addRemoteGit at /usr/lib/node_modules/npm/node_modules/which/node_modules/isexe/mode.js:8:5npm WARN addRemoteGit at /usr/lib/node_modules/npm/node_modules/graceful-fs/polyfills.js:284:29

    npm WARN addRemoteGit at FSReqWrap.oncomplete (fs.js:152:21) code: 'ENOGIT' }


    npm

    ERR! git clone --template=/root/.npm/_git-remotes/_templates --mirror https://github.com/swissmanu/ltx.git /root/.npm/_git-remotes/git-https-github-com-swissmanu-ltx-git-cdata-for-ltx-parser-d923f26b: undefinednpm ERR! git clone --template=/root/.npm/_git-remotes/_templates --mirror https://github.com/swissmanu/ltx.git /root/.npm/_git-remotes/git-https-github-com-swissmanu-ltx-git-cdata-for-ltx-parser-d923f26b: undefined


    npm

    WARN deprecated node-xmpp-stanza@1.1.0: use @xmpp/xml package <https://www.npmjs.com/package/@xmpp/xml>

    npm


    ERR!

    code ENOGIT

    npm ERR!

    not found: git

    npm

    ERR!

    npm

    ERR!

    Failed using git.npm ERR! This is most likely not a problem with npm itself.

    npm ERR! Please check if you have git installed and in your PATH.



    npm ERR! A complete log of this run can be found in:npm ERR! /root/.npm/_logs/2018-08-06T19_43_19_476Z-debug.log


    host.raspberrypi install adapter harmony

    npm install iobroker.harmony --production --prefix "/opt/iobroker" (System call)

    npm


    WARN addRemoteGit Error: not found: gitnpm WARN addRemoteGit at getNotFoundError (/usr/lib/node_modules/npm/node_modules/which/which.js:13:12)

    npm WARN addRemoteGit at F (/usr/lib/node_modules/npm/node_modules/which/which.js:68:19)

    npm WARN addRemoteGit at E (/usr/lib/node_modules/npm/node_modules/which/which.js:80:29)

    npm WARN addRemoteGit at /usr/lib/node_modules/npm/node_modules/which/which.js:89:16

    npm WARN addRemoteGit at /usr/lib/node_modules/npm/node_modules/which/node_modules/isexe/index.js:42:5

    npm WARN addRemoteGit at /usr/lib/node_modules/npm/node_modules/which/node_modules/isexe/mode.js:8:5

    npm WARN addRemoteGit at /usr/lib/node_modules/npm/node_modules/graceful-fs/polyfills.js:284:29

    npm WARN addRemoteGit at FSReqWrap.oncomplete (fs.js:152:21)

    npm WARN addRemoteGit git+https://github.com/swissmanu/ltx.git#cdata-for-ltx-parser resetting remote /root/.npm/_git-remotes/git-https-github-com-swissmanu-ltx-git-cdata-for-ltx-parser-d923f26b because of error: { Error: not found: git

    npm WARN addRemoteGit at getNotFoundError (/usr/lib/node_modules/npm/node_modules/which/which.js:13:12)

    npm WARN addRemoteGit at F (/usr/lib/node_modules/npm/node_modules/which/which.js:68:19)

    npm WARN addRemoteGit at E (/usr/lib/node_modules/npm/node_modules/which/which.js:80:29)

    npm WARN addRemoteGit at /usr/lib/node_modules/npm/node_modules/which/which.js:89:16

    npm WARN addRemoteGit at /usr/lib/node_modules/npm/node_modules/which/node_modules/isexe/index.js:42:5

    npm WARN addRemoteGit at /usr/lib/node_modules/npm/node_modules/which/node_modules/isexe/mode.js:8:5

    npm WARN addRemoteGit at /usr/lib/node_modules/npm/node_modules/graceful-fs/polyfills.js:284:29

    npm WARN addRemoteGit at FSReqWrap.oncomplete (fs.js:152:21) code: 'ENOGIT' }


    npm ERR! git clone --template=/root/.npm/_git-remotes/_templates --mirror https://github.com/swissmanu/ltx.git /root/.npm/_git-remotes/git-https-github-com-swissmanu-ltx-git-cdata-for-ltx-parser-d923f26b: undefinednpm ERR!

    git clone --template=/root/.npm/_git-remotes/_templates --mirror https://github.com/swissmanu/ltx.git /root/.npm/_git-remotes/git-https-github-com-swissmanu-ltx-git-cdata-for-ltx-parser-d923f26b: undefined

    npm WARN deprecated node-xmpp-stanza@1.1.0: use @xmpp/xml package <https://www.npmjs.com/package/@xmpp/xml>

    npm

    ERR! code ENOGIT

    npm

    ERR! not found: gitnpm

    ERR! npm ERR! Failed using git.

    npm ERR! This is most likely not a problem with npm itself.

    npm ERR! Please check if you have git installed and in your PATH.



    npm ERR! A complete log of this run can be found in:npm ERR! /root/.npm/_logs/2018-08-06T19_44_09_533Z-debug.log


    host.raspberrypi install adapter harmony

    ERROR: host.raspberrypi Cannot install harmony

    ERROR: process exited with code 13


    Alle anderen Adapter lassen sich problemlos Installieren.:cursing::cursing::cursing::cursing::cursing::cursing:

  • Zitat

    Error: not found: git

    ...ist aber eigentlich eindeutig :)


    Gibt git --version eine Version aus (glaube 2.7.4 ist aktuell...)

    Die letzten Worte vor dem Weltuntergang: "...das ist technisch völlig unmöglich..."


    aktuelle Projekte: <<< Magic Mirror +++ RMS +++ Wetterstation +++ Somfy Fernbedienung >>>