Problem beim Anlernen des Broadlink mit ioBroker

  • Nein.

    Hab den Broadlink2 Version 1.8.0 installiert, weil ich den Broadlink + habe und dieser nicht mit dem RM3 Adapter funktioniert

    Mein Broadlink Pro + ist leider noch im "Zulauf". Sobald er eintrifft stelle ich das mal nach.

  • Hallo svenlausw .

    So meine ersten Gehversuche mit meinem nagelneuen Broadlink Pro Plus sind gemach. Die da waren.


    Installation des BL in das eigene Netzwerk. OK

    Erste Gehversuche mit der BL - App OK

    neuen BL-Adapter im IB angelegt ( RM3 ) ERROR

    .BL-Adaper geht offline wenn ich versuche in der Konfig einen Butten zum anlernen anlegen möchte

    . BL geht nicht in den Lernmodus ( über true/false)

    . BL deinstalliert OK

    neues BL-Adapter BL 2.0 installiert OK

    FB "Power on" angelernt, lässt sich über IB schalten, Schalter umbenannt in FERNSEHER AN

    Funktion in den Cloud-Adapter übernommen, Alexa auf Gerätesuche geschickt OK

    "Alexa Schalte FERNSEHER AN" ERROR

    "Alexa Schalte FERNSEHER AN ein" OK TV ist an

    "Alexa Schalte FERNSEHER AN ein" , ein weiteres mal - TV geht aus :-/ ERROR


    SZENE nachgebaut wie hier im Video zu sehen

    Szene in den Cloud-Adapter übernommen, Alexa auf die "Suche" geschickt OK


    "Alexa Schalte FERNSEHER AN" TV geht an OK

    "Alexa Schalte FERNSEHER AUS" TV geht aus OK



    So weit so gut.



    Als ich das ganze dann für CHANNEL + bzw.CHANNEL - machen wollte war ich dann mit meinem Wissen am ende ERROR :)


    Ich hänge fest an der Stelle das ich eine Scene für Programme rauf bzw. Programme runter erstellt habe. Die Plapperdose will aber immer noch ein

    "Alexa Schalte PROGRAMM HOCH ein" bzw. "Alexa Schalte PROGRAMM RUNTER ein" haben. Ich werde das EIN /AUS einfach nicht los !!!! :-(




    Sehe hier den Fehler nicht und brauche mal einen Tipp, wie andere das gelöst haben !

  • Ich komme, trotz der freundlicherweise zur Verfügung gestellten Fotos, leider auch nicht weiter! :-(

    Ich denke, das Problem ist die unterschiedliche Konfiguration. Wenn ich das richtig sehe, hast Du, fabmad, einen Schalter, der mit dem gleichen Signal ein- und ausschaltet (klassischer Ein-/Aus-Schalter wie auf der Fernbedienung des TV).

    Bei mir haben die Steckdosen allerdings jeweils ein eigenes Signal für ein und aus! Daher brauche ich, jeweils einen Ein- und einen Ausschalter und dann zusätzlich noch, wie im Video auch beschrieben, den "Schalter" (finde den Begriff etwas irritierend) - also eine Art übergeordnete Instanz, die auf Zuruf entweder den Ein- oder den Ausschalter betätigt und sich den Schaltzustand auch noch merkt. Eben genau die Konfiguration, wie im Video - nur daß die beim weißen Adapter eben nicht einfach so replizierbar ist! :-(

  • Das ist auch genau auch mein Problem.


    Die angelernte Tastenfunktion lässt sich problemlos steuern. Aber immer nur mit "schalte Taste-xy AN"


    Das hier gezeigt Script von Dennis bekomme ich nicht zu laufen.


    ( Es müsste sich doch unter OBJEKT starten lassen ???? )

  • Frickelmaster


    Vielleich kann er ja mal ein paar Lösungansätze hier zum besten geben.

    Laut seiner Signatur betreibt er auch eine BL PRO mit RF Steckdosen.

    Ich wiederhole mich ungern... unterm Strich taugt aus meiner Sicht der Broadlink2-Adapter nix! Der lässt sich komfortabel konfigurieren und die Fernbedienungscodes sind fix angelernt... sowohl IR als auch RF. Aber irgendwie ist in dem Ding der Wurm drin, der vergisst die Konfiguration irgendwann und macht nur Mist.


    Meine Erfahrungen decken sich mit denen von Dennis, der das auch in seinem Video so beschreibt. Also in den sauren Apfel beissen und den "alten" BL-Adapter nehmen und einrichten. Spielt einwandfrei.


    Der Kram, den man direkt im BL2-Adapter in der Instanz einstellen kann, kann man auch mit Javascript oder Blockly machen...

  • Blöd ist nur das ich den BL.0 bei mir nicht mit meinem BL Pro+ zu rennen bekommen habe.
    Sonst hätte ich den viel lieber genommen!


    Kann man die grundsätzlich beide parallel installieren ? Oder kommen die sich ins "Gehege" ?

  • Auf die Idee, das parallel auszuprobieren, bin ich noch nicht gekommen. Ohne es näher untersucht zu haben vermute ich aber mal, dass das nicht gut gehen kann.


    Also "entweder - oder", gleichzeitig würde ich das nicht installieren.


    Übrigens setze ich gerade meinen ioBroker neu auf, weil ich den Adapter für Amazon Dash nicht ans Laufen bekommen. Also jetzt 1:1 nach Dennis' Videoanleitung... allerdings werde ich das ganze Broadlink-Zeugs usw. nicht mehr einspielen, ich schiess einfach ein Backup rein :-)


    Vielleicht ist das ja auch ne Idee für Dich, Ralf? Backup machen und dann neu installieren. Sicherheitshalber kannste ja ne andere SD-Karte nehmen oder ein Image des jetzigen ziehen, dann kann nix in die Hose gehen.

  • Ich habe es auch zuerst nach Dennis' Anleitung mit dem alten schwarzen Adapter versucht. Bringt nur leider nichts, weil ich einen der neuen Broadlinks habe, bei denen das Anlernen dann nicht mehr funktioniert! Von daher bleibt mir keine andere Wahl, als den neuen weißen Adapter zu nehmen! Das Einzige, was evtl. noch funktionieren könnte, wäre beide Adapter parallel zu benutzen - den weißen nur zum Anlernen (was ja mit dem schwarzen nicht klappt) und den schwarzen dann zum Ausführen der Funktionen. Inwiefern diese Bastellösung dann aber wieder klappt (selbst wenn man den weißen später löscht, um Konflikte zu vermeiden), steht auch in den Sternen... Kann aber doch auch eigentlich nicht sein, daß man bei dem (wie ich finde guten!) weißen Adapter keinen Schalter mit zwei verschiedenen Frequenzen für ein und aus zum Laufen bekommen kann?!

  • Also.


    ( Backups habe ich ein paar im Sack :))


    Nach zwei Tagen vergeblicher Versuche den BL.0 mit meinen PRO+ zu laufen zu bekommen, muss ich nach folgendem LOG Eintrag erkennen:


    host.IOBROKER 2018-01-21 20:01:49.908 info Restart adapter system.adapter.broadlink.0 because enabled

    host.IOBROKER 2018-01-21 20:01:49.908 error instance system.adapter.broadlink.0 terminated with code 0 (OK)

    broadlink.0 2018-01-21 20:01:49.861 info Closed connection/listener

    broadlink.0 2018-01-21 20:01:49.861 error at processImmediate [as _immediateCallback] (timers.js:383:17)

    broadlink.0 2018-01-21 20:01:49.861 error at Immediate._onImmediate (c:\iobroker\node_modules\iobroker.js-controller\lib\adapter.js:3194:38)

    broadlink.0 2018-01-21 20:01:49.861 error at Adapter.emit (events.js:172:7)

    broadlink.0 2018-01-21 20:01:49.861 error at emitTwo (events.js:87:13)

    broadlink.0 2018-01-21 20:01:49.861 error at Adapter. (c:\iobroker\node_modules\iobroker.broadlink\main.js:31:6)

    broadlink.0 2018-01-21 20:01:49.861 error at enterLeaningMode (c:\iobroker\node_modules\iobroker.broadlink\main.js:105:16)

    broadlink.0 2018-01-21 20:01:49.861 error TypeError: currentDevice.enterLearning is not a function

    broadlink.0 2018-01-21 20:01:49.846 error uncaught exception: currentDevice.enterLearning is not a function

    broadlink.0 2018-01-21 20:01:49.814 info Enter learning mode - Wait 30 seconds for data before leaving...

    broadlink.0 2018-01-21 20:01:29.441 info Device connected: 192.168.1.30 (Unknown)

    broadlink.0 2018-01-21 20:01:28.879 info Discover UDP devices

    broadlink.0 2018-01-21 20:01:28.879 info starting. Version 0.1.1 in c:/iobroker/node_modules/iobroker.broadlink, node: v4.5.0



    Keine Chance mit dem aktuellsten BL PRO PLUS mit dem Adapter BL.0 ( schwarzer Adapter ) <X

  • Hast Du die aktuellste Firmware auf dem Ding drauf? Meiner hat auch rumgezickt, aber mit der Firmware 20028 läuft der einwandfrei. Kann man blöderweise nur über die App aktualisieren. Hardwareversion hab ich gerade nicht parat, müsste runterrennen und das Kistchen mal aus der Halterung an der Wand nehmen, um auf's Etikett zu gucken :-)

  • Keine Ahnung, ob Du mich meinst (ich denke mal, eher Ralf?), aber bei mir ist die 20025 drauf. Laut der App ihc, mit der ich das Teil benutze, ist das auch die derzeit aktuellste für meine neue Version des RM Pro.


    Bei mir besteht wie gesagt nur das Problem mit der richtigen Einrichtung des "Schalters", ansonsten habe ich alles zum Laufen gebracht. Wäre schön, wenn jemand, der ebenfalls den weißen Adapter benutzt, mir mal den Code seines Schalters hochladen könnte (und am besten noch ein Bild von der Verzeichnisstruktur, damit ich sehe, an welcher Stelle er angelegt wurde).

  • Wäre schön, wenn jemand, der ebenfalls den weißen Adapter benutzt, mir mal den Code seines Schalters hochladen könnte

    Richtig, es war Ralf gemeint ;-)


    Hast Du den vermeintlich "alten" Adapter auch mal getestet? Der funktioniert - im Gegensatz zur Version 2 - nämlich problemlos, zumindest mit ca. 2 Monate alten Broadlinks. BL2 macht mächtig Probleme, das solltest Du zwischenzeitlich gelesen haben...

  • Firmwareupdate habe ich ( mit der App ) bei den ersten Gehversuchen gemacht.


    Und nach einem Wochenende des Ausprobieren habe ich es nun grundsätzlich am laufen !


    Wie so oft steckt die Tücke im Detail. Dazu hier eine kurze Zusammenfassung


    Mit der Hardware Broadlink PRO PLUS läuft der Adapter BROADLINK für RM3/mini definitiv nicht! Hier scheitert der Adapter schon an der Anlernfunktion und stürzt dabei ab. ( Sie LOG oben )


    Der Adapter BROADLINK2 funktioniert bei mir ohne Fehler mit dem Broadlink PRO PLUS

    Es lassen sich RF- und IR-Signale problemlos anlernen.

    ( Abgeschmiert ist mir der Adapter in der Version 1.8.0 bis dato auch noch nicht. )



    Meine Problem beruhten auf der Tatsache das die ganze Hardware für mich komplett neu war.

    Ich hatte gewissen Wünsche auf was die Quasselbüchse reagieren sollte.

    Nach einem anlernen einer Schaltfunktion war diese grundsätzlich vorhanden. Der Syntax für Alexa war aber nicht so, wie ich es haben wollte.


    Ich wollte kein "Alexa, schalte FERNSEHER EIN an" . Ich wollte eine "Alexa, schalte FERNSEHER an"


    Das war nur in einer sogn. SZENE zu lösen und klappte dank Dennis Video auch ziemlich flott.

    Richtig haarig wurde es aber bei einem Gerät, das sowohl einen Schalter für EIN, als auch für AUS hat. Z.B eine IR-Fernbedienung für ein RGB-Stripe oder eine Baumarkt RF-Steckdose.

    Hier kam man mit dem Video von Dennis nicht weiter. Er hat für diese Situation ein Script für einen "Schalter" gebaut.

    ( Man könnte besser von einer SZENE sprechen)

    Das ließ sich aber nicht eins zu eins von dem Adapter für den BROADLINK für RM3/mini auf den Adapter BROADLINK2 umsetzten.

    Hier habe ich ziemlich lange experimentieren müssen, bis es funktionierte.

    Konkret funktionier nämlich genau das anlegen eines "Schalters" ( einer Szene ) nicht so , wie von Dennis beschrieben.


    Erst als ich die vom Adapter mit installierte Beispiel-Szene "Scenes.Fernsehen" für meinen "Schalter" kopiert und in meinem Script genutzt habe , lief alles so wie ich es wollte.


    Es gilt als jetzt mal zu klären wo und warum hier die Unterschiede sind.


    Dazu später mal mehr.

  • Bei mir besteht wie gesagt nur das Problem mit der richtigen Einrichtung des "Schalters", ansonsten habe ich alles zum Laufen gebracht. Wäre schön, wenn jemand, der ebenfalls den weißen Adapter benutzt, mir mal den Code seines Schalters hochladen könnte (und am besten noch ein Bild von der Verzeichnisstruktur, damit ich sehe, an welcher Stelle er angelegt wurde).

    Will ich gerne machen, alleine um es selber zu verstehen ! :)

    (Brauch dafür nur etwas Zeit und Ruhe. Bin @work)

  • @ Frickelmaster: Den alten habe ich wie gesagt schon getestet, aber da funktioniert das Anlernen nicht! Scheint eine generelle Inkompatibilität mit den neuen RM Pros zu sein. Daher muß ich den neuen weißen Adapter verwenden - es besteht allenfalls die Möglichkeit, die mit dem weißen Adapter angelernten Signale in den schwarzen zu übertragen. Aber ob das wirklich so klappt und der schwarze Adapter dann auch tatsächlich die Codes des weißen versteht...?


    Ralf: Dein längerer Beitrag weiter oben (von vor etwa einer Stunde) beschreibt exakt mein Problem! Der "Schalter" (Szene trifft es in der Tat besser) klappt nicht mit Funksteckdosen, die ein separates Signal für ein und aus benutzen. Wäre super, wenn Du Deinen Code (und vielleicht noch ein paar zusätzliche Angaben zum Erstellen) dann später mal hochladen könntest!!