[Xiaomi SmartHome] Ohne Gateway oder Cloud dafür mit CC2531 Zigbee Stick [Tutorial]

  • Dann kann ich dir jetzt eigentlich nur noch folgenden Tipp geben:
    Geh mal in das ioBroker.net Forum. Zigbee benutzt einen Converter. Wir benutzen noch den alten von Shepherd, der nicht mehr weiter entwickelt wird. Seit einiger Zeit ist man in diesem Forum auf den Herdmans-Converter gewechselt, ist jedoch damit auch noch in der Erprobung. Das hat auch zur Folge, dass man den neuen Zigbee-Adapter 1.x benötigt. Da müsstest du dich mal ein bisschen einlesen. Ich kann da nicht weiterhelfen, da ich das selbst noch nicht gemacht habe.

  • [quote='Live Side','https://www.schimmer-media.de/forum/index.php?thread/1744-xiaomi-smarthome-ohne-gateway-oder-cloud-dafu-r-mit-cc2531-zigbee-stick-tutorial/&postID=31822#post31822']

    Hat jemand denn die aktuelle version für dein Zigbee stick?

    [/quote]

    Aktuell ist ja etwas relativ, denn die letzte Version für den CC2531 (irgendwas mit 2.X) müsste vom 20190608 sein. Mittlerweile gibt es 3.0, der CC2531 hat aber zu wenig Speicher dafür. Der Stick wird irgendwann überholt sein.

  • Aktuell ist ja etwas relativ, denn die letzte Version für den CC2531 (irgendwas mit 2.X) müsste vom 20190608 sein. Mittlerweile gibt es 3.0, der CC2531 hat aber zu wenig Speicher dafür. Der Stick wird irgendwann überholt sein.

    Wie du schon gesagt hast ist überholt du kannst den noch behalten oder was besseres vor allen mit sehr guter Reichweite dieses Board holen. eine sehr gute Info gibt es hier.

  • Da wir noch sehr am Anfang dieses Projektes sind, warte ich erst mal die Entwicklung ein bisschen ab.
    Ich bin jetzt eh einen anderen Weg gegangen. Alles von Xiaomi lasse ich über zwei Gateways laufen und den wenigen Rest (Osram, Tradfri) über den ZigBee Stick. Seitdem läuft ZigBee auch ganz entspannt und ohne Probleme. Man konnte hier wirklich merken, je mehr Sachen am Stick angemeldet waren, desto mehr Aussetzer gab es.

  • Welches XIAOMI-Teil willst Du koppeln?

    Mein Praxis-Tipp: Im Adapter das Koppeln starten, den Knopf am XIAOMI drücken, bis es blinkt, dann loslassen, es blinkt noch einmal, dann alle 1-2 Sekunden den Knopf drücken, bis der Countdown runtergelaufen ist.

    Immer mal wieder variieren und probieren!

    ioBroker: Pi3B / Sonoff -Basic / Mobile.0 / Shelly2.5 (Rollladen)

    ZigBee: Pi2B RaspBee-GW DeConz / Philips Hue Dimmer-Switch, Hue/Innr-Leuchten / XIAOMI Mi/Aqara Fenster-, BWM-Sensor, Magic Cube

    EQ-3 Max! Cube, Ventile, Thermostate / Logitech Harmony Elite mit Hub / Roborock S5

    Tasmota durch TasmoAdmin (&Atom.IO) / AVM FB 7490 / Devolo Magic 1 Powerline

  • Hallo,


    nach dem ich 22 Seite durchgelesen habe, muss ich leider sagen das ich es noch nicht hinbekommen habe. Ich habe einen fertigen Stick "CC2531 ZigBee USB zigbee2mqtt For ioBroker FHEM Magnet Antenne 8dbi + Firmware" von Ebay. Wenn ich diesen in mein raspberry pistecke und eingebe



    pi@raspberrypi:~ $ lsusb

    Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub

    Bus 001 Device 005: ID 0451:16ae Texas Instruments, Inc.

    Bus 001 Device 002: ID 2109:3431 VIA Labs, Inc. Hub

    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub


    wir dieser auch als Texas Instruments, Inc. erkannt. Unter


    pi@raspberrypi:~ $ ls -la /dev


    finde ich auch


    lrwxrwxrwx 1 root root 5 Feb 24 17:26 serial1 -> ttyS0


    Jetzt kommts wenn ich


    pi@raspberrypi:~ $ ls -la /dev/serial/by-id


    eingebe bekomme ich folgende Fehlermeldung


    ls: cannot access '/dev/serial/by-id': No such file or directory


    beim Zigbee Adapter wird mir /dev/ttyS0 vorgeschlagen. Allerdings bleibt der Adapter gelb wenn ich es auswähle und speichere auch ein Neustart brachte nichts.


    Was mache ich Falsch / wo liegt der Fehler?





    Schon mal vielen Dank im Vorraus für Eure Hilfe