Autostart vom ioBroker

  • so. nach ausgiebiger recherche nun die infos:


    crontab ist nur sinnvoll, wenn man einen automatischen neustart zu einem bestimmten datum/uhrzeit machen möchte.


    der quellcode von mera für die broker.sh datei ist falsch und muss außerdem wenn er richtig gewesen wäre per


    Code
    1. sudo chmod 755 /etc/init.d/beispiel


    aktiviert und mit


    Code
    1. sudo update-rc.d beispiel defaults


    ausgeführt werden. erst dann ist der autostartbefehl unter rcconf einsehbar.

  • Funktioniert nicht ist die schlechteste Rückmeldung die du geben kannst.

    Jetzt mal alles was du gemacht hast.


    Wo liegt die iobroker.sh Datei?

    Welche Rechte hat die Datei?


    Was ist die Rückgabe von "sudo update-rc.d beispiel defaults"?

  • Ich hatte das gleiche Problem. Bei mir existierte die iobroker.sh nicht in /etc/init.d/ -Habe eine iobroker.sh angelegt und den exakten inhalt rein kopiert ohne dass es funktioniert hatte. Habe dann im iobroker Forum einen Thread mit dem Thema nicht funktionierender Autostart gefunden. Das müsste dieser gewesen sein.


    Code
    1. update-rc.d iobroker.sh defaults

    Den habe ich in /etc/init.d/ mit meiner zusammengeschusterten iobroker.sh ausgeführt. Vorher den root aktiviert und mit chmod den Rechte auf die iobroker.sh gesetzt. Neustart und ging.


    Ich übernehme keine Garantie. Alles aus meinem Gedächnisprotokoll ;)

  • Was auch sein kann ist, dass du den Autostart von ioBroker zu erst an machen musst.



    Code
    1. sudo systemctl enable service.service

    sollte damit gehen.

    nein funktioniert nicht.




    Ich hatte das gleiche Problem. Bei mir existierte die iobroker.sh nicht in /etc/init.d/ -Habe eine iobroker.sh angelegt und den exakten inhalt rein kopiert ohne dass es funktioniert hatte. Habe dann im iobroker Forum einen Thread mit dem Thema nicht funktionierender Autostart gefunden. Das müsste dieser gewesen sein.


    Code
    1. update-rc.d iobroker.sh defaults

    Den habe ich in /etc/init.d/ mit meiner zusammengeschusterten iobroker.sh ausgeführt. Vorher den root aktiviert und mit chmod den Rechte auf die iobroker.sh gesetzt. Neustart und ging.


    Ich übernehme keine Garantie. Alles aus meinem Gedächnisprotokoll ;)

    versuche ich heute mal

  • bei mir funktioniert der ioBroker Start auch nicht. Ich habe ioBroker in einer VM installiert das Script angelegt root Rechte vergeben aber es funktioniert noch immer nicht. VM ist ein Debian der neusten Art.

    Was kann ich noch machen..?


    Welche Infos braucht ihr noch..?

  • Hallo zusammen,


    ich kenne das Prblem mit dem fehlenden Autostart nur zu gut.


    Komischerweise habe ich das Problem ausschließlich bei der PI3 Serie.

    Bei meinen PiZeroW hatte ich noch nie dieses Problem.


    Bei mir hat es letztendlich so funktioniert:

    (Ich möchte nicht behaupten, dass dieser technisch korrekt ist. Ich bin auch kein Linux Profi !)


    Checkt mal welche NPM ihr installiert habt.



    bei der 4.x wird die /etc/init.d/iobroker.sh überhaupt nicht angelegt. siehe auch HIER

    Btw: die NPM4 musste ich installieren, da sich mit der aktuellsten NPM der AmazonDash Button Adapter nicht installieren ließ.


    am besten Ihr legt in diesen Fall die iobroker.sh zunächst mal mit folgendem Inhalt an: (alles mit Sudo)


    chmod habe ich 777 vergeben


    Anschließend habe ich noch die rc.local im Verzeichnisch /etc/ angepasst:



    Neustarten und hoffen ;-)


    Viel Erfolg


    Über Eure Rückmeldung/Verbesserung würde ich mich freuen.


    Wauzzi