Xiaomi Aqara Gateway in ioBroker einbinden

  • Hier von einen Kollegen die Anleitung.


    Also ich habe gestern mein V3 Gateway bekommen und konnte es in der Mi Home App (Android Galaxy S9+) hinzufügen und den Key auslesen.

    Ich hatte anfänglich Probleme da ich das Gateway in meinen Computerzimmer (Keller) anmelden wollte. Das hat nicht geklappt! Dann hoch ins Wohnzimmer, eingestöpselt und Suchen lassen und siehe da, es wurde sofort gefunden. Wahrscheinnlich, weil ich im Keller kein GPS-Signal habe. Wofür das auch immer gebraucht werden mag? Dann hat es zwar mehrere Versuche gebraucht, bis sich das Gateway in das heimische Netzwerk (Fritzbox) eingeloggt hat, aber danach funktionierte alles soweit.

    Bei Android kommt man an den Key, wenn man folgende Schritte in der Mi Home App vollzieht.



    Startseite Mi Home App - Auswahl des Mi Control Hub


    Oben recht den Kreis mit den 3 Punkten auswählen


    Den Punkt "Über" anwählen (es erscheint eine Seite mit Auswahl "Smart Home Kit Forum")


    Dann mehrfach auf der restlichen leeren Seite schnell rumklicken

    Es erscheint ein neuer Auswahldialog "Wireless communication protocol"


    Diesen auswählen und dann sieht man den Token (Key) hinter Password


    Hat bei mir auf Anhieb geklappt!"

    Genau so habe ich es gemacht und das ging sofort..... nur musste ich meine 2. Gateway in den schon Installierten Adapter eintragen, es geht nicht den Adapter zweimal zu Installieren :-)

    hier der Original-Link

  • Hallo Leutz,


    habe Heute meine Mi Home Gateway installiert, wollte nun auch Sie im IObroker anzeigen lassen.

    Aber der Adapter bleibt GELB (Verbindung mit MI Home Falsch). ich habe den KEY eingegeben.


    Woran kann es liegen, das der Adapter nicht läuft??


    MFG Benny

  • Hallo zusammen,


    ich habe auch das Gateway V3 und mir geht es genau wie Benny - mein Adapter bleibt gelb.

    Im Log steht:


    mihome.0 2019-04-14 18:41:19.341 info States connected to redis: 127.0.0.1:6379
    mihome.0 2019-04-14 18:41:19.466 info Change connection status: false
    mihome.0 2019-04-14 18:41:19.450 info starting. Version 1.2.5 in C:/ioBroker/node_modules/iobroker.mihome, node: v8.12.0

    Ich konnte online noch nichts dazu finden. Einzig eine Anleitung die empfielt einige Pins anzulöten, um dann mit nem Programmiergerät und Putty ein paar Befehle abzusetzen: https://forum.iobroker.net/top…r-gelben-mihome-adapter/2


    Das hört sich etwas gruselig an und ich hab keine Lust das Teil gleich zu bricken.

    Habt ihr eventuell einen Tipp?

  • Hallo....habe grade ein Update des Adapters gemacht und habe jetzt auch das Problem das der Adapter auf Gelb steht und keine Verbindung aufbaut. Ich habe immer 2 V2 Gateways ohne Probleme mit der alten Version ansprechen können doch nach dem Update geht nichts mehr. Gibts für das Problem schon ne Lösung bzw. kann ich irgendwie auf eine ältere Version zurück?

  • Hallo....habe grade ein Update des Adapters gemacht und habe jetzt auch das Problem das der Adapter auf Gelb steht und keine Verbindung aufbaut. Ich habe immer 2 V2 Gateways ohne Probleme mit der alten Version ansprechen können doch nach dem Update geht nichts mehr. Gibts für das Problem schon ne Lösung bzw. kann ich irgendwie auf eine ältere Version zurück?

    Ich hab mir ja ein neues Gateways V2 gecheckt und hatte plötzlich Probleme mit der ioBroker-Verbindung. Dachte mir dann, dass eventuell dass das Update helfen könnte. Hat aber nichts geändert. Leider kann ich dir keinen sinnvollen Hinweis geben, aber ich kann dir sagen, dass es nach einigen Gateway-Restarts und der Neu-Generierung dieser ID in den Gateway Settings dann plötzlich wieder funktioniert hat. Seit dem rennt es ohne Probleme.


    Komisch ist auch, dass ich ja mit meinem V3 Gateway, welches ich dann verkauft habe, nie eine Verbindung zustandegebracht habe. Das neue Gateway ist angeblich ein V2, das WLAN, welches das Teil bei der Erstkonfiguration öffnet enthält jedoch den Text "V3". Funktionieren tut es dennoch ... alles höchst mysteriös.


    Ich bin ja insgesamt sehr zufrieden mit den ganzen Aqara Sensoren, aber ich greife gerade das Gateway äußerst ungern an, weil man echt nicht weiß, ob es bei der nächsten Änderung wieder die Zusammenarbeit mit dem ioBroker verweigert :/