Neuer Sonoff Basic oder ganz altes Modell?

  • Die Konfiguration klappt das ist ja nicht soo kompliziert wenn das nur das in den Einstellungen ist... Aber das toggle ist bei generic auch weg oder? Und das Schalten danach mit Schalter klappt nicht. Ein Kabel muss doch an gnd und eins an GPIO2 oder?

  • Kabel GND und GPIO2 stimmt. Wenn Du bei einem "Generica" Modul alle Einstellungen nachgestellt hast, wie sie bei einem Original-Basic sind gibt's auch das Toggle. Toggle verschwindet zB wenn kein Relais, also kein Ausgang konfiguriert ist, egal ob es körperlich angeschlossen ist - es muß konfiguriert sein...

  • Hallo zusammen,

    bin gerade dabei meinen Sonoff Basic zu flashen. Wie ich hier bereits rausgefunden habe gibt es eine "neu" Version vom Sonoff Basic und diesen habe ich auch.


    Zu meinem Problem:

    Ich habe versucht das Video von Dennis zum Sonoff Basic Flash nach zu machen. Leider scheitert es bei mir beim kompilieren in Arduino. Fehler in Arduino lautet:

    WARNUNG: Bibliothek NewPing-1.9.1 behauptet auf (avr, arm) Architektur(en) ausgeführt werden zu können und ist möglicherweise inkompatibel mit Ihrem derzeitigen Board, welches auf (esp8266) Architektur(en) ausgeführt wird.


    Hat jemand da eine Idee und kann mir bitte weiter helfen?

  • Also ich hab mit Atom geflasht gibt es auch ganz gute Videos zu was man da beachten muss. Wenn das flashen geklappt hat verbindet sich der sonoff noch nicht mit dem WLAN dann einfach 4 mal hintereinander den Knopf auf dem sonoff drücken...dieser macht dann ein eigenes WLAN zur Konfiguration auf und man kann seine WLAN Daten eintragen.

    Wenn das auch klappt und man will noch einen Aufputz Schalter anschließen muss man diesen bei den neuen am einfachsten auf RX oder TX anschließen...dafür dann in den Einstellungen von dem sonoff (einfach die IP Adresse im Browser eingeben) auf 18 generic stellen dann auf Speichern und dann wieder darauf dann hat man mehrere Möglichkeiten dann RX oder TX (so wie angeschlossen) auf Switch ändern, dann GPIO12 auf relay1 stellen und GPIO13 auf LED1 und dann sollte auch der Schalter funktionieren.

  • Danke für die schnelle Antwort, aber ich hab es auch bereits mit Atom probiert aber da kommt dann auch ein error (welchen muss ich nochmal nachschauen und melde mich dann).

    Kannst du mir bitte die Links zu den Dateien schicken die du benutzt hast?

  • Hallo, ich hätte auch eine Frage bezüglich der neuen Version. Leider habe ich auch diese nun bekommen. Selbst das Einrichten mit der original Software und Firmware geht nicht. Quick pairing geht nicht, alternatives pairing, quasi dem alten ähnelt (das Licht blinkt schnell) geht, allerdings ist der Sonoff Basic immer offline. Er will sich nicht connecten.

    ssid habe ich simplen namen gewählt extra dafür. Hat jemand es überhaupt geschafft die neue Version einzurichten bei sich mit original Software? und wenn ja, wie? Router ist eingestellt auf 2,4ghz n b g standard Wlan.
    Ich wüsste nicht was ich noch machen sollte. Selbst das Passwort habe ich schon simple gemacht. Verschlüsselung ist WPA+WPA2 eingestellt, eigentlich will ich nicht WEP versuchen ;)

    Gibt es irgendwo ein schon ein Video über die neue Version und wie sie zu flashen ist?

    Bin ziemlich neu auf dem Gebiet, deswegen habe ich erstmal viele Fragen :)


    Bin dankbar für jede Hilfe.

    Gruß

    Adrian


    P.S. Für die, die es interessiert hier die Lösung: E liegt an der SSID, die darf anscheind nicht zu lang sein. 6 Zeichen ging ohne Probleme 16 und drüber Zeichen nein. ZUmindest war das für mich die Lösung. Nächster Schritt ist also das flashen. Damit er sich auch in meinen normalen Netzwerk anmelden kann.

  • Ja klar ist das nicht das Wunschergebnis, aber ich wollte erstmal sehen ob die überhaupt funktionieren.

    Zu SSid das hat mich nicht in ruhe gelassen mit den 6 Zeichen. Weil dazu müsste ich alles bei mir umstellen. Nein Danke. Also habe ich den wieder in den Einstellungsmodus versetzt und nun wieder mit der Ursprünglichen SSid eingerichtet. Es geht. Das ist echt sehr merkwürdiges Verhalten. Ersteinrichtung ging damit gar nicht. Ich habe unzählige Male versucht. Nachdem ich den aber einmal mit der 6 Zeichen lange Ssid eingerichtet habe, akzeptiert er nun auch längere. Für mich ergibt das keinen Sinn. Aber falls jemand genauso solche Probleme hat, der sollte das mal versuchen, bevor er am verzweifeln ist.


    Wie gesagt das sind nur meine Erfahrungen. Vielleicht hat jemand andere.