Visualisierung lässt sich nicht installieren

  • Hallo Freunde des Smart Home,

    Ich komme gleich mal gleich zur Sache.

    Letztens wollte ich das erste mal in meinen Iobroker die Visualisierung starten.

    Dies hat jedoch nicht funktioniert. Wollte dann den Adapter manuell installieren. Das hat leider auch nicht funktioniert (Editor log Anhang).

    Vielleicht sollte man auch erwähnen das der iobroker jedesmal Manuel nach dem Neustart des Rasperry pi gestärkt werden muss. Daher geht jetzt meine Frage an euch was genau läuft im System nicht richtig? Da beim installieren jedes Mal die Installation mit Fehlermeldungen abgebrochen wird (und nach dem Befehl iobroker Upload vis verändert sich daran auch nix)


    Der Befehl npm Audit fix bringt auch nix


    Danke schonmal im Vorraus

  • root/.node-gyp/11.6.0/include/node/v8config.h:326:3: note: in definition of macro ‘V8_DEPRECATED’

    declarator __attribute__((deprecated(message)))

    ^~~~~~~~~~

    unix_dgram.target.mk:99: die Regel für Ziel „Release/obj.target/unix_dgram/src/unix_dgram.o“ scheiterte

    make: *** [Release/obj.target/unix_dgram/src/unix_dgram.o] Fehler 1

    make: Verzeichnis „/opt/iobroker/node_modules/unix-dgram/build“ wird verlassen

    gyp ERR! build error

    gyp ERR! stack Error: `make` failed with exit code: 2

    gyp ERR! stack at ChildProcess.onExit (/usr/local/lib/node_modules/npm/node_modules/node-gyp/lib/build.js:262:23)

    gyp ERR! stack at ChildProcess.emit (events.js:188:13)

    gyp ERR! stack at Process.ChildProcess._handle.onexit (internal/child_process.js:254:12)

    gyp ERR! System Linux 4.14.98-v7+

    gyp ERR! command "/usr/local/bin/node" "/usr/local/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js" "rebuild"

    gyp ERR! cwd /opt/iobroker/node_modules/unix-dgram

    gyp ERR! node -v v11.6.0

    gyp ERR! node-gyp -v v3.8.0

    gyp ERR! not ok


    > iobroker.vis@1.1.10 install /opt/iobroker/node_modules/iobroker.vis

    > node main.js --install


    npm WARN optional SKIPPING OPTIONAL DEPENDENCY: unix-dgram@0.2.3 (node_modules/unix-dgram):

    npm WARN optional SKIPPING OPTIONAL DEPENDENCY: unix-dgram@0.2.3 install: `node-gyp rebuild`

    npm WARN optional SKIPPING OPTIONAL DEPENDENCY: Exit status 1


    + iobroker.vis@1.1.10

    updated 1 package and audited 2671 packages in 46.395s

    found 40 vulnerabilities (28 low, 12 high)

    run `npm audit fix` to fix them, or `npm audit` for details