Sonoff 4 ch Pro Flashmodus

  • Tag zusammen,

    folgendes Problemchen stellt sich mir gerade. Ich habe hier einen Sonoff 4 CH Pro der augenscheinlich nicht geflasht werden möchte ...oder mache ich was falsch.

    Sobald ich den FTDI Adapter starte und dabei GND und den GPIO Pin dabei brücke und den Button FW gedrück halte (das tue ich auf dem Bild nicht), leuchten bei mir 3 LEDs. Im Flashmodus bin ich aber scheinbar damit nicht. Habe auch schon RX und TX gekreuzt, was aber das selbe Ergebnis liefert. Gibts Vorschläge?


    Gruß knoppers

  • Hallo Knoppers007,


    bist du mittlerweile weiter gekommen?
    Ich möchte nämlich auch einen Pro flashen, stehe aber in dem Thema noch ganz am Anfang.


    Es gibt auf dem Board zweimal eine Reihe mit 3,3 V, TX, RX und GND. Einmal mit J1 und einmal mit J6 beschriftet. Welche ist denn da nun die richtige??:/

    Gruß
    vokamale

  • Ich habe schon beide Versionen geflashed und keine Unterschieden festgestellt.

    Den Plan des Gerätes findest du hier https://www.itead.cc/wiki/imag…ff_4ch_pro-Schedmatic.pdf.

    GPIO 0 ist Key1, GPIO 2 an SDA. (Pin1 der Leiste an der auf 3v3, Rx, Tx, und Gnd sind).


    Also die J1 mit den 5 Pins, nicht die J6 mit 4 Pins die geht zum STM...


    Also sicherstellen das SDA nicht!! belegt wird und somit über den internen Pullup an 3v3 = 1 liegt. Ggf. zur Sicherheit mit irgendwas zwischen 3k und 10k an 3v3 legen.


    Rx an Tx, Tx an Rx.


    Key1 drücken, dann erst 3v3 an den entsprechenden Pin legen. Key1 loslassen und flashen.


    Hier ist es auf Youtube:

    Nicht mit Key1 sondern einer Brücke (so habe ich es immer gemacht).

    Key1 sollte laut Schaltplan aber auch gehen.


    Sollte das flashen immer noch nicht klappen ggf. mal die Baudrate ändern. Meist geht 115200 manchmal auch 9600, in seltenen Fällen 74880. (Die kann z.B. der Nodemcu firmware flasher. http://www.nodemcu.com)