Iobroker update js controller Probleme

  • Hi, ich hoffe mir kann da jemand helfen. Ich habe jetzt mehrmal versucht den js controller zu aktualisieren, auf ne Version größer 2, weil die aktuelle Version vom Alexa Adapter sonst nicht geht. Leider bricht das Update immer mit Fehlern ab und danach kann ich nicht mehr auf den Iobroker zugreifen und muss komplett alles neu aufsetzten, neues Image auf SD Karte, Iobroker neu installieren und Backup einspielen.

    Ich habe es laut Beschreibung so versucht.

    sudo iobroker stop

    sudo iobroker upgrate self

    danach geht nix mehr, auch das Fix nicht und auch ne Iobroker Installation drüberbügeln hilft nicht.

    Vielleicht hat ja jemand einen Rat.

    Ich habe nen Raspberry Pi 4 mit 4 GB und Raspian Duster Lite drauf

  • Vielen Dank für die schnelle Antwort.

    Ok, das werde ich die Tage mal testen, wenn ich etwas mehr Zeit habe. Ich will mir erst mal ein Image von der Karte erstellen, damit ich für alles gerüstet bin, ich habe mir noch ne zweite SD Karte bestellt, damit ich zur Not einfach umstecken kann. Ist schon blöd wenn nix mehr läuft.

    Was bewirkt denn der Befehl iobroker update?

  • Der Update befehl bewirkt das die neusten Pakete vom Server geladen werden.

    Wenn Du zum Beispiel einen Installationszustand von Dez. 2018 hast, Du jetzt den Befehl Upgrade startest,

    nimmt er Dez. 2018 als Referenz und will die Installationsdatei von Dez. 2018 installieren.


    Wenn Du jetzt ein update durchlaufen lässt, läd er die aktuellste Version vom Server und hinterlegt diese.
    Somit wärst Du dann bei Jan. 2020 und Dein Upgrade würde nun diese Version aus Jan. 2020 als Referenz nehmen.

    Hoffe Du verstehst was ich mein,


    Grüße

  • Hi, hat leider wieder nicht geklappt. Ich habe folgende Fehlermeldungen im Log erhalten.


    npm WARN ajv-keywords@2.1.1 requires a peer of ajv@^5.0.0 but none is installed. You must install peer dependencies yourself.

    npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@2.1.2 (node_modules/fsevents):

    npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@2.1.2: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"arm"})

    npm WARN optional SKIPPING OPTIONAL DEPENDENCY: osx-temperature-sensor@1.0.4 (node_modules/osx-temperature-sensor):

    npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for osx-temperature-sensor@1.0.4: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"arm"})


    npm ERR! code ELIFECYCLE

    npm ERR! errno 100

    npm ERR! iobroker@2.0.3 postinstall: `node lib/install.js`

    npm ERR! Exit status 100

    npm ERR!

    npm ERR! Failed at the iobroker@2.0.3 postinstall script.

    npm ERR! This is probably not a problem with npm. There is likely additional logging output above.


    npm ERR! A complete log of this run can be found in:

    npm ERR! /home/iobroker/.npm/_logs/2020-01-14T15_31_39_290Z-debug.log

    host.raspberrypi Cannot install iobroker.js-controller@2.1.1: 100

  • Im ersten Teil steht alles beschrieben:


    npm WARN ajv-keywords@2.1.1 requires a peer of ajv@^5.0.0 but none is installed. You must install peer dependencies yourself.


    Und die weiteren Meldungen musst Du auch abarbeiten.


    Auch wenn ein Hinweis darauf hindeutet das NPM nicht das Problem selbst, ist, welche Version hast Du denn aktuell drauf?

    " node -v " <------ eingeben und LOG posten. 


    Grüße

  • Hi, ich habe die Version 10.18.0

    Das heißt also, das ich alles was laut Log fehlt selber nach installieren muß, oder ?

    Puh, und das wo ich nicht gerade der Linux Experte bin.

    Ich hatte vorher wohl auch nicht das komplette Log gepostet, hier noch mal die gesamte Ausgabe.

  • So wie es im Log steht, ja.

    Allerdings gibt wohl noch eine Variante:


    Ich würde es mal hiermit versuchen:


    https://github.com/ioBroker/ioBroker/wiki/Installation


    Weiter unten ist zu lesen:



    Update Installation (Permissions, Access Rights, ...)

    The installation as described above takes also care of setting correct permissions.......

    The version of your installation is included in a file called ......

    in https://github.com/ioBroker/io…NGELOG_INSTALLER_LINUX.md what

    was updated after you installed ioBroker...........


    Nun der Teil der für Dich vielleicht von Interesse ist:


    For older installations or to update your installation to the latest installation version we have created a installation fixer script that is capable to update all installations to the same level. The changelog of this fixer can be found at https://github.com/ioBroker/io…/CHANGELOG_FIXER_LINUX.md

    Running the Installation fixer is as easy as installing. Simply execute


    curl -sL https://raw.githubusercontent.com/ioBroker/ioBroker/stable-installer/fix_installation.sh | bash -


    and follow the instructions. You need to stop ioBroker before running the script!!



    Ich rate zum Backup! 


    Grüße

  • Hi, vielen Dank für die Antwort. Leider hat das auch nicht geholfen.

    Ich habe jetzt einfach ne Iobroker installation über mein System laufen lassen und siehe da es hat geklappt. Version 2.1.1 js-controller ist drauf und fast alles lief sofort wieder, bis auf den TR-064 Adapter, aber das Problem ist bekannt unter js-controller Version größer 2. Habe da erst mal die Community Version installiert und es läuft.

    Ich habe das gefühl, das mein Problem von meiner Backup Variante her kam, bei der ich bestimmte Iobroker Ordner komplett speichere (Iobroker-data und node_modules) und dann wieder als Backup einfüge. Mein Backup von nem älteren Raspberry 3 System habe ich mit auf den Raspberry 4 genommen und das hat wahrscheinlich alles durcheinander gebracht.

    Vielen Dank für deine Mühe und deine Tips.