USB Auto Backup Tool ioBroker Raspberry

  • Tool nochmal runterladen. Gab n update. USB rausziehen. (Nur in deinem Fall). Mit Tool Unmounten. Raspy neu starten. USB dann wieder in den Raspy. Mounten.

    Meinst du mich jetzt oder einen anderen?

    Grüße Franz

    Raspberry Pi3, ioBroker, Broadlink Pro, Broadlink Mini, Harmony Hub, WD My Cloud, Funksteckdosen 433 MHz, Danny3 Sonoff Touch, Osram Smart+Plug, TP-Link HS 110 Wlan Steckdose, Xiaomi Yeelight, 2 Xiaomi Gateways + sämtliche Sensoren, Alexa, Google Home, iPad Air2, iMac.


  • Dich.. :)

    Okay alles klar Ich danke dir.

    Ich mache mich gleich an die Arbeit:thumbup:

    Grüße Franz

    Raspberry Pi3, ioBroker, Broadlink Pro, Broadlink Mini, Harmony Hub, WD My Cloud, Funksteckdosen 433 MHz, Danny3 Sonoff Touch, Osram Smart+Plug, TP-Link HS 110 Wlan Steckdose, Xiaomi Yeelight, 2 Xiaomi Gateways + sämtliche Sensoren, Alexa, Google Home, iPad Air2, iMac.


  • Tool nochmal runterladen. Gab n update. USB rausziehen. (Nur in deinem Fall). Mit Tool Unmounten. Raspy neu starten. USB dann wieder in den Raspy. Mounten.

    Habe ich gemacht leider ohne Erfolg.


    schimmer-media.de/index.php?attachment/1824/

    Grüße Franz

    Raspberry Pi3, ioBroker, Broadlink Pro, Broadlink Mini, Harmony Hub, WD My Cloud, Funksteckdosen 433 MHz, Danny3 Sonoff Touch, Osram Smart+Plug, TP-Link HS 110 Wlan Steckdose, Xiaomi Yeelight, 2 Xiaomi Gateways + sämtliche Sensoren, Alexa, Google Home, iPad Air2, iMac.


    Einmal editiert, zuletzt von Franz ()

  • So. In meinem Tool musst Du eine kleine Änderung machen. Und zwar im Ordner /Programm/Programm ist eine normale Text- Datei mit den Namen "USB.txt". Oder nur "USB". txt muss nicht umbedingt angezeigt werden. Den mit einem normalen Editor öffnen.

    Dort steht so was in etwa:

    Code
    1. sudo mount -t vfat -o utf8,uid=pi,gid=pi,noatime /dev/sda1 /media/usbstick

    Da änderst Du einfach das sda1 um in sdb1. So z.B.


    Code
    1. sudo mount -t vfat -o utf8,uid=pi,gid=pi,noatime /dev/sdb1 /media/usbstick

    Dann speichern und fertig.

    Das musst Du dir merken für Später. Wenns mal Updates gibt vom Tool. Werde das eventuell auch so machen das man den kompletten Gerätenamen eingeben muss, statt nur die "Zahl". Mal gucken

  • Hallo Elzershark


    Es läuft wieder!!!!

    So einfach kann es sein wenn man weiß was man zu tun hat:D

    Musste praktisch nur einen Buchstaben ändern, und schon läuft es.

    Vielen vielen Dank, auf dich kann man sich immer verlassen.:thumbup::thumbup::thumbup:

    Grüße Franz

    Raspberry Pi3, ioBroker, Broadlink Pro, Broadlink Mini, Harmony Hub, WD My Cloud, Funksteckdosen 433 MHz, Danny3 Sonoff Touch, Osram Smart+Plug, TP-Link HS 110 Wlan Steckdose, Xiaomi Yeelight, 2 Xiaomi Gateways + sämtliche Sensoren, Alexa, Google Home, iPad Air2, iMac.


  • Gibt eine Änderung in meinem Tool.

    Mann muss jetzt immer den Pfad vom USB Stick eingeben anstatt nur die Nummer.

    Für diejenigen die z.B. den USB-Stick als sdb1, sdc1 u.s.w. angezeigt bekommen bei der ersten Installation.

    Beschreiben auf der Webseite

    Alles klar zur Kenntnis genommen.

    Dankeschön:D:thumbup:

    Grüße Franz

    Raspberry Pi3, ioBroker, Broadlink Pro, Broadlink Mini, Harmony Hub, WD My Cloud, Funksteckdosen 433 MHz, Danny3 Sonoff Touch, Osram Smart+Plug, TP-Link HS 110 Wlan Steckdose, Xiaomi Yeelight, 2 Xiaomi Gateways + sämtliche Sensoren, Alexa, Google Home, iPad Air2, iMac.


  • @hotwebnet

    geh mal in den iobrokerTool/Programm/programm


    dort findest du ca. 10 text Dateien...da du Ubuntu nutz (so wie ich)... musst du überall wo "sudo iobroker" steht noch das wort service davor setzen.


    sollte dann in der ersten textdatei so aussehen:


    cd /opt/iobroker/

    sudo service iobroker stop

    sudo rm -r archive.tar.gz

    sudo tar -czf archive.tar.gz iobroker-data node_modules

    sudo service iobroker start


    habe die änderungen mal fett markiert um es besser darstellen zu können...

    das machst du mit den restlichen textdateien auch so...natürlich die änderungen speichern...dann sollte es funktionieren mit dem backup

  • Glaube wenn Du jetzt dein Raspi neu startest, wird dein sdb1 wieder zu sdba1. So ist es bei mir jedenfalls. Dann wieder USB neu installieren (vorher unmounten) dann (1 drücken bei "USB"). Die Daten wieder eingeben. Ab jetzt bleibt der USB auf sda1.. Jedenfalls bei mir.. :)

    Ok. Alles klar, und danke für die Info:thumbup:

    Grüße Franz

    Raspberry Pi3, ioBroker, Broadlink Pro, Broadlink Mini, Harmony Hub, WD My Cloud, Funksteckdosen 433 MHz, Danny3 Sonoff Touch, Osram Smart+Plug, TP-Link HS 110 Wlan Steckdose, Xiaomi Yeelight, 2 Xiaomi Gateways + sämtliche Sensoren, Alexa, Google Home, iPad Air2, iMac.


  • Hallo,


    Kann man das Tool noch irgendwo downloaden, der Youtube-Link funktioniert leider nicht

    Ja kann man und zwar einmal hier und einmal hier

    Grüße Franz

    Raspberry Pi3, ioBroker, Broadlink Pro, Broadlink Mini, Harmony Hub, WD My Cloud, Funksteckdosen 433 MHz, Danny3 Sonoff Touch, Osram Smart+Plug, TP-Link HS 110 Wlan Steckdose, Xiaomi Yeelight, 2 Xiaomi Gateways + sämtliche Sensoren, Alexa, Google Home, iPad Air2, iMac.


  • Hallo Elzershark,


    vielen Dank für das Programm und die Anleitung. Bei mir startet der Raspi täglich neu über crontab. Wenn ich das automatische Backup aktiviere macht er keine Sicherung auf dem USB Stick da der Stick ja nicht gemountet ist. Gibt es eine Möglichkeit das der USB Stick nach neustart des Raspi automatisch gemountet wird?


    Gruß Stöcki