Sonoff Touch MQTT Verbindung fehlgeschlagen

  • Hallo,

    Ich habe 4 Sonoffs mit Tasmota geflasht.

    Einen Sonoff Touch, einen 4ch, einen Touch T1 und einen Basic. Bei allen hat das flashen gut geklappt und bei allen außer bei dem Sonoff Touch funktioniert die Verbindung zu MQTT auch. :thumbup:

    Nun das Problem:

    Bei dem Touch steht in der Konsole „MQT: Verbindung fehlgeschlagen auf Grund von (IP des Raspberrys), rc -2. Wiederversuch in 10 Sekunden.

    Die Daten, welche bei MQTT eingetragen werden müssen, sind alle korrekt, habe diese 100 mal eingegeben. :)

    Hoffe ihr könnt mir irgendwie weiter helfen. :S

  • Hast du versucht den einfach nochmal zu flashen? Weil wenn wirklich alles 100 mal schon eingegeben wurde, würde ich einfach mal neu aufsetzen. Vllt nicht die Antwort die du hören, willst, aber wenn du das noch nicht versucht hast...


    viel erfolg

  • Hab ich schon gemacht, das erste mal hab ich mit Atom geflasht und das zweite mal mir arduino. Hab schon überlegt ob ich lieber eine ältere Firmware Version nehme... muss ich mich nur erkundigen wie das alles so funktioniert.:/

  • Habe es gerade irgendwie hinbekommen hab nochmal auf eine alte Version geflasht danach nochmal auf die neue mit anderen MQTT Einstellungen also „#define MQTT_LIBRARY_TYPE ... “ geflasht.

    Also habe von den Library Types alle 3 ausprobiert hat aber immernoch nicht funktioniert.

    Habe dann auf die Standart Library Type geflasht auf der es vorher auch war (MQTT_PubSubClient), nochmal geguckt und auf ein mal war er drin ??

  • Hallo, ich habe leider mit einem geflashten 4Ch pro genau das gleiche Problem wie zu begin beschrieben. Habe von 5.10 bis 5.14 schon jeder firmware probiert. Leider immer der gleiche Fehler. Könnt ihr mir evtl. hier nochmals den Tip geben, mit welcher Kombination von Adapter, Firmware und 4CH pro es jemand am laufen hat?


    Grüße und Danke

  • Es ist aber nicht gleichzeitig der MQTT-Adapter auf dem gleichen Port aktiv ?

    ioBroker: Pi3B / Sonoff -Basic / Mobile.0 / Shelly2.5 (Rollladen)

    ZigBee: Pi2B RaspBee-GW DeConz / Philips Hue Dimmer-Switch, Hue/Innr-Leuchten / XIAOMI Mi/Aqara Fenster-, BWM-Sensor, Magic Cube

    EQ-3 Max! Cube, Ventile, Thermostate / Logitech Harmony Elite mit Hub / Roborock S5

    Tasmota durch TasmoAdmin (&Atom.IO) / AVM FB 7490 / Devolo Magic 1 Powerline

  • Ev. ist das Passwort zu kurz. Versuche doch mal was wie 123456 (natürlich nur zum testen :) )

    Die letzten Worte vor dem Weltuntergang: "...das ist technisch völlig unmöglich..."


    aktuelle Projekte: <<< Magic Mirror +++ RMS +++ Wetterstation +++ Somfy Fernbedienung >>>

  • Hm das ist es leider auch nicht. Hatte auch schon ein längeres PW.


    Inzwischen ahbe ich das Problem auch mit meinem TH-10.

    Habe aktuell auf beiden Geräten die 5.12 Firmware.


    Ich muss doch in den Einstellungen nur USER, PW, und Host eintragen oder?

    Für die Host IP nehme ich die IP die mir meine FritzBox für den Pi anzeigt. Das müsste doch passen oder?


    Grüße

    Michael

  • Hi, Problem hat sich auf wundersame Weise über Nacht gelöst.

    Keine Ahnung was da schief lief. Heute morgen konnte ich wieder alle Sonoffs über MQTT ansteuern/auslesen.


    Grüße