Sonoff Touch MQTT Verbindung fehlgeschlagen

  • Habe jetzt witzigerweise dasselbe problem nach update auf 5.14. erst ging es, nach stromunterbrechung ist ein 4ch nicht zu erreichen per mqtt - aber alles korrekt


    update: ein neustart von raspi half nix, netzwerk auch nicht. aber danach extra sonoff-adapter neu gestartet und es funzt wieder tadellos.

  • Hi,


    also nach ein paar Tagen Testphase muss ich sagen, das funktioniert alles andere als stabil. Meine beiden Sonoffs (TH10 und CH4 pro) können leider nur sehr sporadisch über den Adapter angesprochen werden. Habe das Problem aber auch mit einer älteren Firmware z.B. 5.10. Jemand noch eine Idee? Neustart des Adapters, ioBroker oder des raspi bringt nichts.

  • Ja,

    ich habe die Firmware im Atom.IO selbst neu übersetzt und dabei wohl die Libraries 2.3.0 statt 2.4.0 ausgewählt, denen schlechtere WLAN-Performance nachgesagt wird. Irgendwo in platform.io oder so suchen.

    Die 5.14.0 läuft hier brauchbar.

    SonWEB ansehen !!!!!!!

    ioBroker: Pi3B / Sonoff -Basic / Mobile.0 / Shelly2.5 (Rollladen)

    ZigBee: Pi2B RaspBee-GW DeConz / Philips Hue Dimmer-Switch, Hue/Innr-Leuchten / XIAOMI Mi/Aqara Fenster-, BWM-Sensor, Magic Cube

    EQ-3 Max! Cube, Ventile, Thermostate / Logitech Harmony Elite mit Hub / Roborock S5

    Tasmota durch TasmoAdmin (&Atom.IO) / AVM FB 7490 / Devolo Magic 1 Powerline

  • Hallo,


    danke erst mal für die Antwort. Da ich noch nicht so tief in der Materie drin bin, hätte ich noch ein paar Fragen: 1. Habe ich dich richtig verstanden, dass man die platform = in der Datei platform.io ändern soll? (siehe screenshot)

    2. Kann das flashen mit der neuen bin OTA passieren oder über den FTDI


    Grüße und wie immer vielen Dank

  • Ja, ich empfehle, die v2.3 zu nutzen. War bei mir bei der 5.13.1 ein deutlicher Unterschied den WLAN-Performance. 5.14.0a habe ich jetzt nur heruntergeladen und installiert (SonWEB!!!) und läuft bei mir.


    Du mußt die Minimal- und die DE-Version übersetzen, dann kannst Du erst die Minimal per OTA installieren und anschließend die DE-Version aus Platzgründen.

    ioBroker: Pi3B / Sonoff -Basic / Mobile.0 / Shelly2.5 (Rollladen)

    ZigBee: Pi2B RaspBee-GW DeConz / Philips Hue Dimmer-Switch, Hue/Innr-Leuchten / XIAOMI Mi/Aqara Fenster-, BWM-Sensor, Magic Cube

    EQ-3 Max! Cube, Ventile, Thermostate / Logitech Harmony Elite mit Hub / Roborock S5

    Tasmota durch TasmoAdmin (&Atom.IO) / AVM FB 7490 / Devolo Magic 1 Powerline