Beiträge von MrTea

    Hallo,

    ich habe mir neue SHP6 Steckdosen in China bestellt.

    Diese lassen sich leider nicht per USB-Adapter flashen. Auch OTA geht nicht!

    Der Flashvorgang bricht nach dem Initialisieren ab!

    Bisher war das per USB-Adapter immer möglich.

    Die einzigste Veränderung die ich sehen kann ist eine neue Versionsnummer der Platine.

    von "3R18 - 1939" auf "3R18 1949". Hier mal der Screenvergleich:


    Alte/Bisherige Version (Gosund Sp111/Blitzwolf SHP6):


    Neue Version (Gosund Sp111/Blitzwolf SHP6):


    Kann jemand helfen bzw. Kennt jemand hier eine Lösung?

    VG


    Flasher:

    Hallo,


    sorry ich habe auch eine solche Mail bekommen.

    DAS GEHT ÜBERHAUPT NICHT!


    Ob nun Daten geklaut, Seite gehackt ....
    Dies ist eine nicht freigegebene Nutzung meiner Daten.


    Dennis: Bitte ändere diesen Zustand und gib ein Statement da zu ab. Sonst werde ich meinen Account hier löschen müssen. 


    Das kann (zumal Du von social Media lebst) ja nicht in Deinem Sinne sein!

    Hi,


    nachdem ich die 220V nicht direkt angeschlossen habe, habe ich das mit einem Trafo gelöst:


    1. 220V an Sonoff Basic (für WLAN und zum Schalten per IoBroker)

    2. Ausgang vom Sonoff dann in Trafo zum schalten der 12V (https://www.amazon.de/gp/produ…sc=1&tag=schimmermedia-21)

    3. 12V dann an das Magnetventil (https://www.amazon.de/gp/produ…sc=1&tag=schimmermedia-21)

    4. Das Ganze dann hinten zusammengeklebt und in eine Box gesteckt mit Kabelverschraubungen

    sauber abgedichtet. (https://www.amazon.de/gp/produ…8GBP&tag=schimmermedia-21 https://www.amazon.de/gp/produ…DVD4&tag=schimmermedia-21)


    Was soll ich sagen: Es läuft problemlos und so kann ich jetzt meine smarte Bewässerungsanlage selber programmieren.


    VG


    PS: Wenn jetzt jemand noch einen Tipp für einen smarten Regensensor und/oder Feuchtigkeitssensor hat, wäre das System 100% perfekt!;)

    Hi,


    Jetzt wird es langsam Sommer und ich möchte ein Bewässerungssystem aufbauen.

    Da kommt mir Dennis Anleitung gerade recht.

    Ich habe mir (da ich nicht warten kann) ein 12V Ventil bei https://www.amazon.de/gp/produ…sc=1&tag=schimmermedia-21 bestellt.

    Sollte baugleich mit dem vom Video sein. Einen Sonoff-Basic habe ich zu Hause.


    Nun zu meiner Frage:

    Im Video wird nicht gezeigt, wie der Sonoff intern angeschlossen ist. Man sieht nur die Drähte am Ventil.

    Steuert man das Ventil direkt mit den 220V oder welche Pins sind intern belegt um das Ventil zu steuern?


    Gruss


    s8yw97u4.jpg

    Servus,


    Ich habe einige Kippschalter mit Sonoff Basics bestückt. Somit kann ich den Schalter per GPIO14 schalten und per WLAN sowieso. Soweit so gut.

    Über einen XIAOMI Bewegungsmelder habe ich eine "Fernsteuerung" beim Betreten des Raumes erstellt per Script. Auch das passt alles. Da ich ein Sparfuchs bin, habe ich das Timeout zum ausschalten des Lichtes (wenn keine weitere Bewegung erkannt) auf 2 Minuten gestellt.


    Nun zum Problem: Da der Bewegungsmelder nicht den ganzen Raum scannt, steht man irgendwann im dunkeln wenn man länger als 2 Minuten im Raum ist. Ich habe heute mal die Wäsche im Wirtschaftsraum aufgehängt und bin bald verrückt geworden. Denn das Licht ging immer wieder nach 2 min aus....


    Jetzt könnte ich das Timeout hochsetzen, aber das will ich nicht.

    In den Objekten des Sonor Basic im ioBroker gibt es ja das Objekt "sonoff.0.DVES_8CB24B.Switch1" - dieses sollte doch erkennen wenn der Kippschalter betätigt ist. Ich dachte ich könnte das timeout nur dann erhöhen, wenn man von Hand den Schalter schaltet. Leider ändert sich das Objekt aber nicht bzw. extrem sporadisch.


    Daher habe ich mit "SwitchMode" und "SwitchTopic" von Tasmota rumgespielt.


    SwitchMode 7 - Der Schalter sendet einen Umschaltbefehl, wenn er gedrückt wird, und einen weiteren Umschaltbefehl, wenn er losgelassen wird.

    SwitchTopic 1 - Beim Ändern des Switch-Status wird eine MQTT-Nachricht an das SwitchMode gesendet, deren Nutzdaten dem festgelegten SwitchMode entsprechen.


    Leider bringt das in dem Objekt des ioBrokers KEINE Statusänderung.


    Kann man also das Objekt SWITCH des Sonoff-Basic-Objektes nicht auswerten?

    Oder was mache ich falsch?


    Ich hoffe Ihr könnt helfen.


    Gruss

    Servus zusammen,


    ich stehe etwas auf dem Schlauch.:(

    Folgendes würde ich gerne umsetzen:

    Stromzähler im ioBroker mit einem "Weidmann Elektronik Stromzähler".


    Ich habe den Stromzähler auf das LED geklebt und den Adapter installiert.

    in den Einstellungen habe ich folgendes angegeben:


    c16fa0-1552235469.jpg


    IM LOG kommt ausschließlich:

    smartmeter.0 2019-03-10 17:21:57.278 warn No or too long answer from Serial Device after last request.

    smartmeter.0 2019-03-10 17:21:57.276 info Error: No or too long answer from Serial Device after last request.

    smartmeter.0 2019-03-10 17:19:57.221 info starting. Version 1.2.2 in /opt/iobroker/node_modules/iobroker.smartmeter, node: v8.12.0

    smartmeter.0 2019-03-10 17:19:57.191 info States connected to redis: 127.0.0.1:6379



    Was mache ich falsch?

    Der Stromzähler hat auch 2 Dioden, welche der beiden liest nun die blinkende LED aus?

    Es werden auch unter Objekte KEINE Einträge erzeugt...


    In den Adaptereinstellungen könnte ich "/dev/ttyUSB1" oder

    "/dev/serial/by-id/usb-FTDI_FT230X_Basic_UART_DN067FNY-if00-port0"

    angeben. Was ist hier korrekt?



    Folgende Teile habe ich:

    - "Weidmann Elektronik Stromzähler" - https://www.amazon.de/Weidmann…0ASY?tag=schimmermedia-21

    - Stromzähler der Stadtwerke München - siehe Bild

    - ioBroker läuft auf einem Beelink (Node.js: v8.12.0 - NPM: 6.4.1)



    Ich hoffe Ihr könnt mir helfen!

    VG

    Moin,

    ich habe die Belegung geprüft. Mit GPIO2 konnte ich den Schalter nicht nutzen. Auch kann man im Sonoff Menü GPIO2 nicht mit einem Switch belegen.

    Dagegen hatte ich mit dem Lötpunkt "KEY" Erfolg. Also scheint KEY gleichzusetzen mit GPIO14 zu sein.


    PLATINE

    ABER: Der Schaltvorgang war nicht 100% stabil. Es gab ca. bei jedem 3ten Schaltvorgang am Schalter keine Reaktion am Sonoff.

    Muss da noch ein Widerstand oder so was dazwischen?

    Hallo,


    auch ich habe gestern eine NEUE Lieferung der Sonoff Basic aus China erhalten und

    musste feststellen, dass die Platine geändert wurde.


    Auch die Modellbezeichnung ist jetzt "Sonoff RF R2 POWER V1.0"

    Modellbezeichnung


    Ich habe mir das heute früh mal angesehen:

    1. Flashen mit TASMOTA ging ohne Probleme

    Belegung Flasher      Belegung Sonoff


    2. Einen Schalter an GPIO14 anzubringen scheitert, das ich GPIO14 auf der Platine nicht finde. Ich habe nochmal Bilder gemacht und hoffe die Experten haben einen besseren Blick als ich und finden die passende Stelle auf dem Board.


    Platine vorn   Platine hinten


    Wenn nicht , dann würde es in meinen Augen den Sonoff Basic massiv abwerten und

    ich würde dann auf SHELLY1 umsteigen MÜSSEN.



    Ich freu mich auf Feedback!

    Hallo,

    mal wieder das Thema "Battery percent" und ZigBee.


    Situation ist wie folgt:

    ich habe verschiedene XIAOMI Geräte (Bewegungsmelder, Fensterkontakte, Wassermelder usw.) per cc2530 Stick und Osram Smart+ Steckdose am ioBroker. Soweit klappt auch alles.


    Den Batterie-Status kann man ja über den Zeitstempel bei "Battery percent" auslesen.


    Welchen Wert fragt Ihr für den Batteriestatus ab?

    Zeitstempel oder letzte Änderung?


    Wie groß ist bei Euch die Differenz zwischen "Zeitstempel" und "letzte Änderung"?


    Denn (und das finde ich echt merkwürdig) bei einigen Geräte steht als letzte Änderung

    2. oder 3. Oktober 2018. Also mehr als 4 Wochen. Das kann doch nicht stimmen. Oder?

    Denn dann stimmen ja meine ganzen Batteriewerte auch nicht....


    Nachdem die Geräte aber ansonsten funktionieren, muss die Reichweite zum ioBroker ja gegeben sein.


    Für Hilfe und Anregungen bin ich sehr dankbar!

    Zur Info:


    Auf der Suche im WWW bin ich dann auf eine ganz andere Möglichkeit gestossen.

    Tasmota bietet so genannte RULE-Befehle an. Damit kann man Regeln auf Events festlegen.


    Die beiden Sonoff kommunizieren direkt mit einander übers WLAN und somit autark. Klappt einwandfrei. Die Befehle machen exakt das gleiche wie das Script im IOBroker.


    Im meinem Fall ist das Webinterface des Sonoff mit dem Standardpasswort versehen, ansonsten müsset man dieses in der Befehlszeile noch anpassen. Die RULE-Befehle überstehen auch einen Neustart des Sonoff. Somit perfekt!


    Regel für Schalter 1 (bei mir 192.168.86.245): auch Schalter 2 schalten, wenn Power ON oder OFF


    rule1 on Power1#State=1 do websend [192.168.86.52:80,admin:joker] POWER1 ON endon on Power1#State=0 do websend [192.168.86.52:80,admin:joker] POWER1 OFF endon

    rule1 5 //One-Shot, damit websend nur einmal ausgeführt wird

    rule1 1 //aktivieren von rule1


    Regel für Schalter 2 (bei mir 192.168.86.52): auch Schalter 1 schalten, wenn Power ON oder OFF


    rule1 on Power1#State=1 do websend [192.168.86.245:80,admin:joker] POWER1 ON endon on Power1#State=0 do websend [192.168.86.245:80,admin:joker] POWER1 OFF endon

    rule1 5 //One-Shot, damit websend nur einmal ausgeführt wird

    rule1 1 //aktivieren von rule1


    Die Befehle müssen im WebIF in der Konsole eingegeben werden.

    Dies zur Info.


    Wenn mir jemand trotzdem den BINDE-Befehl von oben erklären kann, wäre ich dankbar.

    Mahlzeit,


    mal eine Verständnisfrage zum BINDE-Befehl.

    Dieser bewirkt ja die Bindung von 2 Objekten. Also beide Zustände sind immer synchron.


    Für eine mit Sonoff Basic umgesetzte Wechselschaltung ist dieser Befehl eigentlich super.

    Denn Schalter 1 würde dann über "BINDE" Schalter 2 direkt mit "schalten" und umgekehrt.


    Nun zur Frage:

    Muss ich den BINDE Befehl immer setzen oder nur einmalig.


    Screen1 Setzt den BINDE Befehl immer wenn der Trigger ausgelöst wird

    oder
    Screen2 Der BINDE Befehl wird nur einmal beim Start des ioBrokers gesetzt.


    Ich hoffe ihr könnt mir hierbei helfen....

    Den BINDE-Befehl kann ich noch gar nicht.

    Ich werde heute Abend mein Script diesbezüglich umbauen.


    Aktuelle habe ich meine Wechselschaltung so gelöst:

    BILD


    Schalter 1 (Sonoff Basic 1) erkennt Änderungen und schaltet den Strom im Schalter 2 (Sonoff Basic 2).

    Schalter 2 dagegen schaltet ja eh den Strom, daher muss dieser Schalter 1 nicht schalten.

    1. Das Event, welches Du abfragst ist "Sonoff--ddd.POWER".

    Es ändert sich doch die Temperatur, nicht POWER.

    Daher -> "Sonoff--ddd.DHT11-01_Temperature


    2. Wieso fragst Du 2 verschiedene Temperatur-Werte ab?

    Einmal "DHT11-01_Temperature" und

    "DHT11-14_Temperature". Sollte das nicht nur EIN Datenpunkt sein?


    3. Die Gradwerte sind doch Zahlenwerte.

    Warum setzt Du die Temperatur in Hochkomma?

    Moin,


    ich verstehe jetzt gar nix mehr. Alle (wirklich ALLE) Trigger gehen seit gestern Abend nicht mehr.


    Ich hatte NPM upgedatet und dann ./reinstall.sh durchgeführt.

    ioBroker und alle Funktionen der Webseite und der Steuerung funktionieren.


    Alle Schalter, Lampen, Steckdosen usw. lassen sich nur noch einzeln ansteuern.

    Alle Objekte sind da und alle Bewegungsmelder funktionieren.

    ABER:

    Alle Events/Trigger führen zu KEINER Reaktion mehr. ;(

    Somit sind fast alle Scripts ohne Funktion, da diese ja fast alle auf einen Event reagieren sollen.

    Beispielsweise:

    Bewegung im Keller (mit Xiaomi Bewegungsmelder), dann Licht für 5 Minuten im Sonoff Basic

    per Blockly Script anschalten.


    Systeminformationen:

    NODE = V8.10.0

    Plattform: linux

    Die Architektur: x64

    CPUs: 4

    Geschwindigkeit: 1528 MHz

    Modell: Intel(R) Celeron(R) CPU N3450 @ 1.10GHz

    RAM: 3.7 GB

    Node.js: v8.12.0

    NPM: v6.4.1

    js-Controller: 1.4.2


    Hat irgendwer eine Idee?

    Ich finde auch per Google irgendwie keinen Hinweis. Zumal alles andere zu 100% klappt.

    Aber ohne Eventsteuerung ist es eher ne schlechte Fernbedienung! :cursing:

    Hi,


    ich hate das gleiche Problem und habe es gelöst.

    Ich habe einen Beelink S1 mit 4GB RAM und WINDOWS gekauft und bin dann mit

    der Installation von Debian gescheitert.


    Hier meine Fehlerbeschreibung:

    [ioBroker - Debian] Umzug auf den Beelink S1 mit 8GB RAM [Tutorial]


    Dann meine Lösung:

    [ioBroker - Debian] Umzug auf den Beelink S1 mit 8GB RAM [Tutorial]


    und mein Feedback nach 1 Monat:

    [ioBroker - Debian] Umzug auf den Beelink S1 mit 8GB RAM [Tutorial]


    Somit gibt es eine Lösung mit Ubuntu!