Beiträge von P-A-L-A-D-I-N

    Entweder könntest du dir einfach ein Handelsübliches System mit 433Mhz Aktoren kaufen, was rel. teuer ist, oder aber, falls du DIY machen möchtest (kannst) könntest du dir eine kleine Schaltung mit z.B. einem

    AT-Tiny 85 o.ä. mit 433 MHz Receiver aufbauen.

    Beide Systeme ob WIFI (2,4GHz) oder 433.MHz Strahlen Funkwellen ab u. bei 433 MHz ist die Strahlungsleistung sogar noch deutlich höher als bei WIFI, deshalb kann ich dein Problem nicht nachvollziehen:/;)

    Die 433Mhz-Geräte empfinde ich im Allgemeinen eigentlich als recht günstig - siehe Beispiel "Baumarktsteckdosen". Im Falle von Sonoff gibt es da ja auch durchaus einige günstige Komponenten, die in Frage kämen, wären sie nur eben nicht zu groß für meine UP-Dosen :-(


    Ein neues System wie den Arduino (richtig geschrieben?) brauche ich im Übrigen nicht, da ich ja schon den Raspi mit iobroker und einen RM Pro habe. Es geht also ausschließlich um die UP-Aktoren, die den im Eingangs-Post formulierten Anforderungen genügen.


    Wegen der Strahlung: WLAN funkt doch dauerhaft, im Gegensatz zum 433Mhz-Funk! Oder habe ich da was Falsches aufgeschnappt? Ich dachte / denke, daß WLAN eine mehr oder weniger dauerhafte Funkverbindung aufbaut (und dadurch permanent strahlt), während RF nur bedarsweise funkt...!? Sollte dem nicht so sein, sollte ich natürlich besser auf WLAN oder einen ganz anderen Standard setzen. An den eingangs geschriebenen Anforderungen bez. Größe der Teile, Erhalt der alten konventionellen Schaltfunktion etc. ändert das allerdings nichts.

    Hallo zusammen,


    ich habe mir kürzlich einige Schlüsselfinder zugelegt, die mit Signalen auf 433 Mhz funken. Den RM Pro habe ich mithilfe der mitgelieferten Fernbedienung bereits erfolgreich angelernt und die Steuerung über das Broadlink Plugin (weiß) klappt auch schon: Wenn ich im Broadlink-Plugin auf das entsprechende Zeichen zum Simulieren des Knopfdrucks klicke, piepst der jeweils angesprochene Schlüsselfinder brav.


    Jetzt würde ich die Schlüsselfinder aber gerne noch als "smarte Geräte" in den Cloud Adapter und damit zu Alexa bringen!

    Ziel des Ganzen ist folgendes: Ich möchte auf das Kommando "Alexa, wo sind meine Autoschlüssel/Hausschlüssel/[...]?" auslösen, daß der entsprechende Schlüsselfinder piept (am besten, mit etwas Verzögerung dazwischen, gleich dreimal oder so, weil einmal in der Regel sicherlich nicht zum Finden reichen dürfte), ohne daß ich dafür noch die Fernbedienung brauche.


    Leider habe ich es bislang nicht geschafft, die verschiedenen Schlüsselfinder als schlaue Geräte in den cloud Adapter zu integrieren! Wenn ich ein smartes Gerät hinzufügen möchte, kann ich den entsprechenden Schlüsselfinder zwar auswählen, er taucht aber anschließend nicht in der Liste der smarten Geräte im Cloud Adapter auf (sein Sript ist übrigens gestartet und grün, mit einem Pausezeichen davor - also alles genau so, wie bei den funktionierenden Funksteckdosen).


    Ich nehme an, es liegt an dem Schritt unter Blockly, das ich wohl brauche. Ich bin nämlich einfach mal davon ausgegangen, daß die Anleitung zu den Steckdosen (die berühmte "Ecklampe") hier einfach mehr oder weniger übertragen werden kann, was aber offenbar nicht so ist. Irgendwo hat sich wohl ein Programmierfehler eingeschlichen (womöglich die Einordnung des Schlüsselfinders als "button" oder so?) oder ich habe vielleicht auch einen Schritt vergessen, den der Cloud Adapter benötigt, bevor er ein smartes Gerät hinzufügen kann?


    Kann mir bitte jemand ab dem erfolgreichen Integrieren des Schlüsselfinders in den Cloud Adapter weiterhelfen?


    Mein Versuchs-Script für Blockly sieht, hier im Falle des rosafarbenen Schlüsselfinders, übrigens so aus:

    on({id: "broadlink2.0.RM:Broadlink-RMPROSUB-8e-fb-32.L.Finder_rosa"/*Finder rosa*/, change: "any"}, function (obj) {

    var value = obj.state.val;

    var oldValue = obj.oldState.val;

    for (var count = 0; count < 3; count++) {

    setState("broadlink2.0.RM:Broadlink-RMPROSUB-8e-fb-32.L.Finder_rosa"/*Finder rosa*/, true);

    }

    });


    Hier noch mein RAW für den Schlüsselfinder selbst, wie es im RM Pro Adapter eingetragen ist (und ja auch per simuliertem Knopfdruck funktioniert):

    {

    "common": {

    "name": "Finder rosa",

    "read": true,

    "write": true,

    "state": "state",

    "role": "button",

    "type": "boolean"

    },

    "type": "state",

    "_id": "broadlink2.0.RM:Broadlink-RMPROSUB-8e-fb-32.L.Finder_rosa",

    "native": {

    "code": "b2631600226422642264642309230a230a230a230a230a230a060000"

    },

    "from": "system.adapter.broadlink2.0",

    "ts": 1519808939611,

    "acl": {

    "object": 1638,

    "state": 1638

    }

    }

    Nochmal zur Sicherheit die (idiotensichere) Rückfrage: D.h. also, wenn ich die Karte, die derzeit in meinem Pi drin ist, mit diesem Tool kopiere, kann ich meinen Raspberry im derzeitigen Zustand komplett sichern bzw., wenn ich mir einen zweiten anschaffen würde, auch "klonen"?

    Hallo miteinander,


    ich suche nach einer Möglichkeit, meine "altmodische" Lichtschaltung per Funk-Unterputz-Aktoren (433Mhz) etwas "schlauer" zu machen.


    Folgendes ist mir dabei wichtig:

    1) Die klassischen Lichtschalter sollen erhalten und voll funktionsfähig bleiben, sodaß man die Lampen unverändert damit an- und ausschalten kann

    2) Die Aktoren müssen sowohl einfache Schaltungen als auch Wechsel- und (wenn möglich) auch Kreuzschaltungen bedienen können

    3) Die Aktoren sollen auf Basis von 433Mhz-Funk funktionieren (damit ich sie per vorhandenem Broadlink RM Pro ansteuern kann) - die Variante mit WLAN ist wegen der andauernden Strahlung nicht so mein Fall

    4) Die Aktoren müssen möglichst kompakt sein, da ich in meinen Unterputzdosen nicht mehr viel Platz habe (die Sonoffs wären wohl leider ein ganzes Stück zu groß)

    5) Die Aktoren sollen möglichst günstig sein - ich habe kein Problem mit "China-Ware", solange sie sicher und einigermaßen zuverlässig arbeitet

    6) (Einige) Aktoren sollen feuchtraumtauglich sein (für die Installation im Bad) und dürfen dann auch ggf. etwas mehr kosten - bei den meisten der Aktoren, die ich benötige, muß das allerdings nicht der Fall sein

    7) Die Aktoren müssen für die Schaltung von LED-Lampen geeignet sein (einige Aktoren funktionieren wohl erst ab einem gewissen Mindestverbrauch, der dummerweise oberhalb dem einer einzelnen E27 LED-Birne mit etwa 6-8 Watt liegt)

    8 ) wenn möglich: Die Aktoren sollten die Schaltzustände auch bei einem Stromausfall beibehalten, also bswp. nicht ein ausgeschaltetes Licht nach einem Stromausfall auf einmal ungefragt einschalten


    Ich habe jede Menge Aktoren im Netz gefunden (z.B. bei Conrad, Pearl / Casacontrol, Amazon usw.), aber leider mangelt es da sehr oft an wichtigen Angaben bzw. einem guten und fähigen Kundendienst. In den Datenblättern stehen oft nicht so wesentliche Angaben (bzw. der "Kundendienst" des Verkäufers oder auch des Herstellers beantwortet wichtige Fragen trotz ausdrücklicher Nachfrage einfach nicht), wie bspw, die Frage, ob die Aktoren auch für Kreuzschaltungen oder die Montage in Feuchträumen geeignet sind oder ob der Schaltzustand nach einem Stromausfall erhalten bleibt.


    Könnt Ihr mir vielleicht konkrete Empfehlungen geben, welche Teile meine o.g. Kriterien alle vollständig (oder zumindest größtenteils) erfüllen würden??

    Hallo miteinander,


    da der Plex Skill für Alexa in Deutschland vermutlich erst zusammen mit der Fertigstellung des Berliner Flughafens oder des Stuttgarter Bahnhofs verfügbar sein dürfte, bin ich noch auf der Suche nach einer praktikablen Lösung, um Musik von meinem NAS (WD MyBook Live) bzw. meinem Plex Media Server (installiert auf einem aktuellen Raspberry Pi) auf meinem Echo Dot wiedergeben zu lassen.


    Die diversen Lösungen, die im Netz kursieren (z.B. über den Umweg über die Bluetooth-Verbindung zu einem Mobiltelefon/Tablet), fand ich leider überhaupt nicht überzeugend...

    Was bringt es mir, wenn ich zwar per Alexa meinem Tablet sagen kann, daß es die Wiedergabe starten oder pausieren soll, aber eben nicht per Sprachwahl den richtigen Interpreten und Titel aus meiner umfangreichen lokalen Musiksammlung auswählen kann?

    Was habe ich von einer super Sprachsteuerung, wenn ich dann aber wiederum auf lächerliche 250 Titel beschränkt bin, die ich zuvor in die Amazon-Wolke hochladen muß (und ich aber einen Titel hören möchte, der dort ausgerechnet nicht enthalten ist)?

    Wieso sollte ich Amazon monatlich Geld dafür bezahlen, Musik anhören zu können, die ich bereits besitze - und die vielen, vielen Gigabyte auch noch erst umständlich auf einen Server in den USA hochladen und von dort wieder per Internet zum Abspielen herunterladen, wo ich die Musik doch bereits ohnehin lokal verfügbar habe?

    Irgendwie ist jede Lösung für sich unausgegoren und unbefriedigend...!


    Gibt es vielleicht eine Möglichkeit, die von Amazon gemachten Einschränkungen mithilfe des "Schweizer Taschenmessers" ioBroker oder auch irgendeinem anderen superschlauen Kniff irgendwie zu umgehen?

    Kodi bspw. kann ja auf die lokale Sammlung zugreifen und läßt sich auch mithilfe der Alexa-Sprachsteuerung vollständig (?) bedienen (siehe Video vom Dezember) - dann sollte das doch auch irgendwie mit Plex möglich sein, oder??


    Nachtrag: Das hier scheint in die Richtung zu gehen, die ich mir vorstelle - ist aber wohl noch im Alpha-Stadium und definitiv auch noch nicht idiotensicher in der Umsetzung: http://forum.iobroker.net/viewtopic.php?f=23&t=8127

    Hey, dann hat Paul also Kontakt mit Dir aufgenommen? :-) Das freut mich! Habe ihm empfohlen, sich mal mit Dir zusammenzusetzen und gemeinsam was auf die Beine zu stellen. Der Kerl ist einfach super und hat immer gute Ideen, wie man für sehr kleines Geld richtig viel herausholen kann.

    Ich möchte meinen Raspberry (derzeit als Plex Media Server und iobroker im Einsatz) gerne zusätzlich auch noch zur Visualisierung und Steuerung meines Smart Home benutzen. Dafür plane ich die Anschaffung eines kleinen Touchscreen - ich dachte an mindestens 7, maximal 10 Zoll, um einen guten Kompromiß aus Lesbarkeit und Energiesparen zu finden.


    Nun habe ich gesehen, daß es für den Raspberry ja das "offizielle" Display mit Multitouch gibt. Das finde ich allerdings reichlich überteuert und "zu viel des Guten" für meine bescheidenen Zwecke.


    Eigentlich hatte ich, noch bevor ich mir den Raspberry zugelegt habe, mit dem Gedanken gespielt, mein kleines, ohnehin schon vorhandenes Fire Tablet (7") hierfür zu benutzen - aber das läßt sich ja meines Wissens nach leider nicht mit dem Raspberry verbinden, da es keinen HDMI-Eingang o.ä. besitzt...

    Oder gibt es da vielleicht auch eine Remote Desktop Lösung wie für den PC?!


    Habt Ihr ansonsten vielleicht noch eine (möglichst eher niedrigpreisige) Kaufempfehlung für mich?

    Auflösung, Blickwinkelstabilität (oder wie sich das schimpft) etc. ist mir nicht so wichtig - der Bildschirm soll lediglich ein "besseres Bedienfeld" werden und keine Videos o.ä. abspielen. Schön wäre aber, wenn es eine gute Energieeffizienz besitzt (Standby und Wake-up-Events lassen sich ja bestimmt per Raspberry umsetzen?) und sich entweder dezent (flach) an der Wand anbringen oder sogar darin versenkt einbauen ließe!

    Du fragst im Trigger auf "geändert" ab - ändere das mal auf "aktualisiert". Wenn Du den Datenpunkt auf false setzt, dann wird der Schalter ausgeschaltet. Wenn das Schalten nicht klappt, weil das Signal nicht angekommen ist (passiert ja bei den BBS ab und an mal), dann kannst Du nämlich ansonsten nicht nochmal "aus" (=false) sagen, weil der Datenpunkt bereits auf false steht. Deswegen "aktualisieren", nicht "geändert".


    Wie Eddy schon schrieb ist auch die Version des Cloud-Adapters wichtig. Bei mir läuft es nicht rund mit der aktuellsten 2.4.4, mit der 2.0.6 dagegen schon. Wenn Du auf Nummer Sicher gehen willst, wähle Version 2.0.5


    Ach ja, für die selbst erzeugten Datenpunkte würde ich eine eigene Struktur wählen und die nicht bei der "Hardware" unterbringen. So hast Du eine vernünftige Übersicht über die Zustände und musst nicht in den verschiedenen Geräten rumhampeln. Funktionieren sollte auch Deine Methode, aber sie wird schnell unübersichtlich und führt dann ggf. zu Fehlern. Siehe meinen Screenshot oben...

    Mit "aktualisiert" statt "geändert" hatte ich es zuvor auch schon zig Mal versucht - anscheinend lag der Fehler wirklich einzig und allein bei dem blöden Cloud Adapter! Ich bin jedenfalls heilfroh, daß es jetzt endlich funktioniert (übrigens mit der aktuellsten Version 2.4.4)!

    Ich fing ja echt schon langsam an, an meinen eigenen Fähigkeiten bzw. meinem Verstand zu zweifeln... Naja, in diesem Falle lag das Problem wohl ausnahmsweise einmal nicht zwischen den Ohren sondern tatsächlich bei der Software.


    Eine Rückfrage noch zu der Struktur: Bei den Skripten kann man ja "neu ordnen", um die Übersicht zu verbessern. Gibt es eine vergleichbare Funktion auch unter Objekte? Möchte nur ungern da jetzt alles wieder neu anlegen - "never touch a running system"...! ;-)


    PS: Vor lauter Euphorie vorhin ganz vergessen: VIELEN, VIELEN DANK EUCH ALLEN FÜR EURE VIELE HILFE UND GEDULD!!!

    Hast du auch den CloudAdapter 2.0.5 ?

    Das gibt's doch nicht!!! :-O


    Ich habe eben mal geschaut - hatte da beim Cloud Adapter eine deutlich ältere Version. Schnell aktualisiert und, siehe da, die Schalter haben sich ohne Probleme in die Cloud eintragen lassen.


    Und jetzt fragt mich nicht wieso und weshalb, aber auf einmal funktionieren auch die Steckdosen - sowohl an, als auch aus! :-O Ich habe nichts anders gemacht als vorher, lediglich die kleine Optimierung von Frickelmaster bez. "ungleich wahr" übernommen (was aber wohl mit dem Einschalten nichts zu tun haben dürfte?!), damit es künftig keine Fehler zum Schaltzustand gibt, und auf einmal geht es!


    Ok, ich hinterfrage die fehlende Logik jetzt nicht weiter sondern freue mich einfach nur, daß es jetzt endlich, endlich klappt!! :-)

    Bei mir scheitert es anscheinend schon beim Anlegen der Datenpunkte, denn das, was ich da anlege (role switch, type Logikwert) läßt sich nicht in den Cloud Adapter übernehmen. Ich kann das Ding zwar im Menü auswählen, aber es wird nicht übernommen/gespeichert, sodaß die Liste smarter Geräte am Ende trotzdem leer bleibt. Irgendwie hatte ich es zuvor geschafft, die switches dort reinzubringen, aber jetzt klappt selbst das nicht mehr.


    Kann es sein, daß die switches in einer bestimmten Ordnerstruktur eingebettet sein müssen oder man bei denen noch extra etwas einstellen muß? Ich zeige Dir mal per Screenshot, wie das nach dem Anlegen bei mir aussieht (und eben nicht klappt).


    Außerdem hier mal noch mein Skript, mit dem ich zwar schon die Steckdose per Echo Dot ausschalten konnte (als die smarten Geräte sich noch irgendwie vorher einrichten ließen), aber eben nicht einschalten (obwohl die Befehlsstruktur für ein und aus absolut identisch ist).

    Es klappt einfach nicht!!! Ich könnte diesen ganzen Elektronikschrott gerade aus dem Fenster werfen, so stinksauer bin ich!

    Egal, was ich mache, egal, welcher Anleitung von welcher Seite ich folge und wie viel Zeit ich in dieses gottverdammte Projekt investiere - am Ende funktioniert es einfach nicht!

    Mit meiner o.g. Lösung war ich "immerhin" schon so weit, daß ich die Steckdose per Alexa ausschalten konnte - das Einschalten hat aber trotzdem nicht geklappt, obwohl die "buttons" selbst ALLE funktionieren, das Skript für ein und aus richtig geschrieben war, die Verweise auf die Geräte dort richtig gesetzt waren usw.


    Kann mir bitte jemand noch einmal SCHRITT FÜR SCHRITT und ganz genau sagen, was ich wo drücken muß (idiotensichere Anleitung!!), um diese sch... Schalter einzurichten?


    Stand der Dinge ist jetzt, nachdem ich die ganzen "Nachbauten" der Anleitungen und eigenen Versuche wieder vollständig gelöscht habe, genau folgender (siehe auch angehängtes Bild "Fehlerfreie Ausgangssituation iobroker"):


    0) Ausgangssituation: Ich verwende den Broadlink 2.0 Adapter (weiß) mit dem NEUEN RM Pro. Ich möchte damit 3 Funksteckdosen (433Mhz, separater Ein- und Ausschalter) und eine smarte Deckenleuchte (mit Musik, Farbwechsel etc.) steuern.


    1) Ich habe für jedes RF Signal der zu steuernden Geräte (ein, aus, Farbwechsel etc.) einen Button angelegt. Jeder dieser Buttons funktioniert, wenn ich im iobroker unter "Objekte" auf "simuliere Knopfdruck" drücke!


    2) Ich habe noch keinen "Schalter" kreiert. => bitte um absolut idiotensichere Anleitung!


    3) Im Cloud-Adapter sind noch keine "Smarten Geräte" angelegt. => ebenso!


    4) Unter alexa.amazon.com werden folglich noch keine smarten Geräte bei der Suche gefunden. => sollte ich alleine schaffen, wenn 2 und 3 erledigt sind!

    @ Frickelmaster: Den alten habe ich wie gesagt schon getestet, aber da funktioniert das Anlernen nicht! Scheint eine generelle Inkompatibilität mit den neuen RM Pros zu sein. Daher muß ich den neuen weißen Adapter verwenden - es besteht allenfalls die Möglichkeit, die mit dem weißen Adapter angelernten Signale in den schwarzen zu übertragen. Aber ob das wirklich so klappt und der schwarze Adapter dann auch tatsächlich die Codes des weißen versteht...?


    Ralf: Dein längerer Beitrag weiter oben (von vor etwa einer Stunde) beschreibt exakt mein Problem! Der "Schalter" (Szene trifft es in der Tat besser) klappt nicht mit Funksteckdosen, die ein separates Signal für ein und aus benutzen. Wäre super, wenn Du Deinen Code (und vielleicht noch ein paar zusätzliche Angaben zum Erstellen) dann später mal hochladen könntest!!

    Keine Ahnung, ob Du mich meinst (ich denke mal, eher Ralf?), aber bei mir ist die 20025 drauf. Laut der App ihc, mit der ich das Teil benutze, ist das auch die derzeit aktuellste für meine neue Version des RM Pro.


    Bei mir besteht wie gesagt nur das Problem mit der richtigen Einrichtung des "Schalters", ansonsten habe ich alles zum Laufen gebracht. Wäre schön, wenn jemand, der ebenfalls den weißen Adapter benutzt, mir mal den Code seines Schalters hochladen könnte (und am besten noch ein Bild von der Verzeichnisstruktur, damit ich sehe, an welcher Stelle er angelegt wurde).

    Ich habe es auch zuerst nach Dennis' Anleitung mit dem alten schwarzen Adapter versucht. Bringt nur leider nichts, weil ich einen der neuen Broadlinks habe, bei denen das Anlernen dann nicht mehr funktioniert! Von daher bleibt mir keine andere Wahl, als den neuen weißen Adapter zu nehmen! Das Einzige, was evtl. noch funktionieren könnte, wäre beide Adapter parallel zu benutzen - den weißen nur zum Anlernen (was ja mit dem schwarzen nicht klappt) und den schwarzen dann zum Ausführen der Funktionen. Inwiefern diese Bastellösung dann aber wieder klappt (selbst wenn man den weißen später löscht, um Konflikte zu vermeiden), steht auch in den Sternen... Kann aber doch auch eigentlich nicht sein, daß man bei dem (wie ich finde guten!) weißen Adapter keinen Schalter mit zwei verschiedenen Frequenzen für ein und aus zum Laufen bekommen kann?!