Beiträge von Madaraxa

    Zunächst einmal willi90 :

    Es handelt sich um mehrere Wandtaster, die ein Erdkabel schalten. Beim Hausbau habe ich nicht gewusst, was ich da je anschließen möchte, aber, dass ich "im Garten" Strom brauche.

    Nachdem der Garten dann angelegt wurde, habe ich eine Außensteckdose angeschlossen und daran einen Lichtschlauch. Es wird also nichts, außer der Steckdose geschaltet. Taste drücken - Status der Steckdose wechseln (von An nach Aus oder andersrum).


    Ich habe aber selber die Lösung gefunden. Da ich mir die Infos in vielen verschiedenen Beiträgen zusammen "raten" musste, schreibe ich hier mal die Lösung:


    Der neue Sonoff Basic hat keinen beschrifteten GPIO14. In einem anderen Beitrag (von 2018) hatte ich gelesen, dass "KEY" = "GPIO14" ist. Dem ist NICHT so. "KEY" ist "GPIO0".

    Statt dessen gibt es beim Sonoff Basic der neuen Version einen Lötpunkt auf der Rückseite der mit "IO2" beschriftet ist. Dies ist "GPIO2". Sodass man meinen Anschlussplan genau so nutzen kann, mit der Änderung, dass nicht "KEY" sondern "IO2" genutzt wird und dem entsprechend bei der Config "GPIO2" auf "Switch1" gelegt wird.

    Das wars. Es funktioniert genau wie gewünscht :)

    Grüße

    Max

    Hey,

    ich hoffe ihr könnt mir helfen. Meine Schaltung aus einem Eltako und einem Sonoff Basic (mit Tasmota 8.1 - GPIO14 als Switch1(9) - auch Switch1n ändert nichts):

    An einem Eltako (S12-100) sind mehrere Wandtaster angeschlossen an '+A1'. Der Neutralleiter an '-A2' .

    An '1' habe ich GND des Sonoff Basic und an '2' habe ich GPIO14 (bzw Key, weil es ein neuer Basic ist) angeschlossen.

    Am Basic sind noch Neutral bei 'N in' angeschlossen und die Phase bei 'L in'. Bei 'L out' ist die Leitung zur Steckdose, die geschaltet wird, angeschlossen.

    Zwischen GPIO14 (bzw KEY) und 3V3 habe ich einen 10k Ohm Widerstand (gemessen 9,8k Ohm) als Pullup geschaltet.

    Wenn ich einen Wandtaster drücke, oder auch den Taster am Eltako selbst, blinkt die LED des Sonoff kurz auf - er registriert also einen Eingang an gpio14. Beim folgenden zweiten Tasterdruck schaltet der Sonoff dann wie gewollt AN bzw AUS (also wechselt den Status).

    Über das Webinterface schaltet der Sonoff direkt. Ebenso über den Taster am Sonoff selbst.

    Es liegt also meiner Meinung nach am "Auslesen" des GPIO14 am Sonoff (Softwareseitig) oder daran, dass der Eltako den Schaltzustand beim ersten Mal zu kurz überträgt (woran ich nichts ändern könnte).

    Vorher hat der Eltako seinen Dienst übrigens problemlos getan (einmal Tasten - Änderung von AN / AUS).

    Hat irgendwer ne Idee?

    Hey,
    Nur zum Abschluss des Themas (von meiner Seite): alles läuft seit Ende Dezember ohne Probleme. Hab zwischenzeitlich aus Versehen schon den FI draußen gehabt und natürlich diverse Neustarts des Internet, Servers, iobroker, etc.
    Garage blieb immer geschlossen.
    Es funktioniert also alles problemlos

    Hey,
    Hab es soeben umgebaut aber noch drei fragen:
    1) ich habe das innere schwarze Kabel nur einseitig gelöst und anschließend statt des braunen Kabels wieder angeschlossen. Gibt es einen Grund, warum du das nicht so vorgesehen hattest? (oder war es nur, damit man auf dem Foto gut erkennt welches Kabel man ändern muss)
    2) es liegen im Ruhezustand 0,06 Volt an den Anschlüssen an (wenn er tastet geht es runter auf ca 0,02 Volt). Ist das normal oder hab ich iwo nen Fehler gemacht?
    3) gibt es ein Szenario bei dem der Taster ungewollt auslöst? Also z.B. Neue IP, Router restart, Stromausfall, etc? Wenn ich im Urlaub wäre, wäre es doof wenn die Garage aufgeht :)
    Danke schon mal. Angeschlossen hab ich alles mal und funktionieren tut es (pulsetime 10 war Initial zu kurz, aber das ist Garagenmotor abhängig denke ich).
    Grüße,
    Max

    Hey. Super, danke für die schnelle Antwort und Hilfe.
    Ich probiere es spätestens morgen aus. Heute gehöre ich (leider) zu denen, die arbeiten müssen :)
    Reicht nen 2,5er Querschnitt für das Kabel? Oder sogar 1,5? Hab kein dickeres. Und das 2,5er nur mit festen Kupferkern (also nicht verdrillte Adern).
    Danke

    Hey.

    Das verstehe ich leider nicht. Ich brauche doch "nur" einen "Schalter", der einen Stromkreis schließt.

    Da sollte ein Koppelrelais doch reichen? Das an dem 230V Ausgang des Sonoff angeschlossen sollte doch an DESSEN Ausgang genau das tun, oder? (also quasi kurzschließen).

    Oder verstehe ich die Funktion eines Koppelrelais nicht :)

    Hey.
    Ich hänge mich hier einfach mal dran.
    Ich habe Ende November sonoff basic bestellt, aber eine neues Layout bekommen. Das Relais sitzt anders und die Leiterbahnen sind teilweise durch Kabel ersetzt. Ein einfaches potentialfrei schalten ist nicht mehr möglich, da die Leiterbahnen, die noch vorhanden sind sehr nah an einander sind und mir das zu kritisch.
    Wie bekomme ich den Ausgang trotzdem potentialfrei? Mit diesen Koppelrelais? Oder einem Optokoppler? Wenn ja, welches günstige kann ich da nehmen? Meinetwegen auch aus China. Zeit habe ich :)
    Vielen Dank im voraus

    Hey.
    Ich habe gesucht und leider nichts genaues gefunden. Bitte erschlagt mich nicht sollte ich einfach blind sein :)
    Ist es möglich ein Schaltsignal über gpio auszugeben? Konkret:
    Bei meinem Garagentormotor gibt es 2 Anschlüsse an die ich einen Taster anschließen könnte um das Tor zu bedienen. Hierbei braucht keine Spannung anzuliegen. Ein 'kurzschließen' mit ner Büroklammer tut seinen Zweck.
    Kann ich ein solches Signal über einen gpio (konkret gpio2 des 'neuen' sonoff basic) senden? Oder bleibt nur der Umweg über ein Koppelrelais am 'normalen' Ausgang?
    Meine Idee war GND und GPIO2 an die Anschlüsse der Garage anzuschließen, gpio2 in tasmota als relay2 zu konfigurieren und dann irgendwie den schaltimpuls auf z. B. 0,1 Sekunde zu setzen. Geht das so?
    Vielen Dank im voraus
    Max