tasmoadmin docker

  • Hallo,


    ich habe eine synology nas und dort denn iobroker im docker laufen. Das läuft auch alles sehr gut und stabil.

    Jetzt wollte ich mal das tasmoadmin docker image testen um meine sonoffs zu warten.

    Ich bekomme das aber leider nicht ans laufen, habe es installiert aber es stoppt gleich wieder wenn ich es starte.

    Ich habe auf dem port 80 ein webserver laufen, kann es daran liegen?


    Auf github wird erklärt das man das auch mit diesem Befehl installieren soll.

    Code
    docker run -it -v /host/data:/data -p 80:80 -e APACHE_SERVER_NAME=tasmoadmin.mydomain --name tasmoadmin raymondmm/tasmoadmin

    dort kann ich ja einen anderen port wählen. Aber was muss ich bei "APACHE_SERVER_NAME" eintragen damit es meine nas ip ist/bleibt.

    Brauche ich die option -v /host/data:/data unbedingt?


    Hat da vieleicht jemand ein Tip für mich?

  • Eigentlich müsstest du dort deine Domain-Suffix eintragen. Bei einer Fritz!Box z.B. fritz.box (für mydomain) wenn man es nicht umbenannt hat. Dann wäre TasmoAdmin unter tasmoadmin.fritz.box erreichbar.

    So wie ich mir die Parameter "zusammenreime" wird damit ein virtueller Apache gestartet. Der dürfte dann natürlich nicht auf Port 80 laufen wenn dort schon ein anderer drauf läuft.

    Die letzten Worte vor dem Weltuntergang: "...das ist technisch völlig unmöglich..."


    aktuelle Projekte: <<< Magic Mirror +++ RMS +++ Wetterstation +++ Somfy Fernbedienung >>>

  • besten dank....


    Code
    docker run -it -v /volume1/docker/tasmoadmin:/data -p 8080:80 -e APACHE_SERVER_NAME=fritz.box --name tasmoadmin raymondmm/tasmoadmin

    so hat es jetzt funktioniert und habe nun auch keinen konflikt mit meiner Homepage.


    vielen dank